jartan
23.12.2021 14:25

Написать программу в паскале:10 элементов до 50 в строку с комментарием через пробел найти сумму чисел с четным порядковым номером сумма массива:в
индекс:i
количество:к
сумма:s​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ggggeorgiyggg
05.06.2020 01:02
 Исполнитель алгоритма — это некоторая абстрактная или реальная (техническая, биологическая или биотехническая) система выполнить действия, предписываемые алгоритмом.
Круг решаемых задач. Каждый исполнитель создается для решения определённого класса задач.
Среда исполнителя. Область, обстановку, условия, в которых действует исполнитель, принято называть средой данного исполнителя.
Система команд исполнителя. Предписание о выполнении отдельного законченного действия исполнителя называется командой.
Совокупность всех команд, которые могут быть выполнены некоторым исполнителем, образует СКИ — систему команд исполнителя.Система отказов исполнителя. Отказ «не понимаю» возникает тогда, когда исполнителю подается команда, не входящая в его СКИ. Отказ «не могу» возникает тогда, когда команда из СКИ не может быть им выполнена в конкретных условиях среды.Режимы работы исполнителя. Для большинства исполнителей предусмотрены режимы непосредственного и программного управления. В первом случае исполнитель ожидает команд от человека и каждую поступившую команду немедленно выполняет. Во втором случае исполнителю сначала задаётся полная последовательность команд (программа), а затем он выполняет все эти команды в автоматическом режиме. Ряд исполнителей работает только в одном из названных режимов.
Формальный исполнитель одну и ту же команду всегда выполняет одинаково.
0,0(0 оценок)
Ответ:
нур821
06.06.2022 12:54

Не знаю можно ли считать ноль, как "мінімальне додатнє", потому не включала

Объяснение:

#include<iostream>

using namespace std;

int main()

{

int l[15];

double min=0,max=0;

for(int i=0;i<15;i++)

{

   cin>>l[i];

   if(l[i]>0&&l[i]<min&&min!=0)

       min=l[i];

       if(min==0&&l[i]>0)

           min=l[i];

   if(l[i]<0&&l[i]>max&&max!=0)

       max=l[i];

       if(max==0&&l[i]<0)

           max=l[i];

}

sort(l,l+15);

cout<<min<<" "<<max<<endl;

cout<<min/max<<endl;

for(int i=14;i>=0;i--)

   cout<<l[i]<<" ";

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота