NastyaDersen2004
23.04.2020 21:38

Составьте программу вывода на экран фразы “ХХХХХХХХ-выдающийся ученый ХХ века”. Фамилия ученого ХХХХХХХХ вводится с клавиатуры.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
polinak022
09.05.2020 04:10
Язык C++.
1. #include <iostream>
using namespace std;
int main() {
    int i;
    cout <<"Введите число: " << endl;
    cin >> i;
    cout << "Вы ввели число: " << i << endl;
    }

2. #include <iostream>
using namespace std;
int main (){
    int i;
    cout << "Vvod" << endl;
    cin >> i;
    i %= 10;
    if(i %2 != 0)
    cout << "Нечетная" << endl;
    else
    cout << "Четная" << endl;
    }

3. #include<iostream>
using namespace std;
int main (){
for(int k = 0; k<4; k++){
cout << "random number = " << rand() << endl;
}
}

4. #include <iostream>
using namespace std;
int main(){
int i,a,b,c;
cin >> i;
c = i%10;
b =(i/10)%10;
a = i/100;
if(i*i==a*a*a+b*b*b+c*c*c)
cout<<"Является."<<endl;
else 
cout<<"Не является."<<endl;
}

5. #include <iostream>
#include <cmath>
const double pi = 3.1415926536;
using namespace std;
int main(){
    float x = 0;    cout << "Введите x: " << endl;
    cin >> x;
    cout << "y = " <<  sin((pi*(3.2+(sqrt(1+x))))/180)/abs(5*x) << endl;
    }

Добавляем "pi" и делим на 180, чтобы "sin" был в градусах.

Блок-схемы смотри во вложении.
1. написать программу и составить к программе блок-схему. составить программу вывода на экран числа,
1. написать программу и составить к программе блок-схему. составить программу вывода на экран числа,
0,0(0 оценок)
Ответ:
ggggdcdxf
09.05.2020 04:10
Var Z:integer;
Begin
Write('Z = ');ReadLn(Z);
if Z>0 then WriteLn('Положительное')
else if Z=0 then WriteLn('Равное нулю')
     else WriteLn('Отрицательное')
End.

Пример:
Z = -5
Отрицательное

Z = 0
Равное нулю

Z = 256
Положительное

Z = 10455
Положительное

Var
   X,Y:real;
Begin
Write('X = ');ReadLn(X);
Write('Y = ');ReadLn(Y);
if (X = 0)and(Y = 0) then WriteLn('Начало координат')
else if (X=0) then Write('Ось абсцисс')
     else if (Y=0) then WriteLn('Ось ординат')
          else if (X>0) then
                  if (Y>0) then WriteLn('Первая четверть')
                  else WriteLn('Вторая четверть')
               else
                  if (Y<0) then WriteLn('Третья четверть')
                  else WriteLn('Четвёртая четверть')
End.

Пример:
X = 0
Y = 0
Начало координат

X = 0
Y = 1
Ось абсцисс

X = 1
Y = 0
Ось ординат

X = 1
Y = 1
Первая четверть

X = 1
Y = -1
Вторая четверть

X = -1
Y = -1
Третья четверть

X = -1
Y = 1
Четвёртая четверть

Var
   a,b,c,S:integer;
Begin
Write('Введите трёхзначное число: ');ReadLn(A);
b:=(a div 10) mod 10;
c:=a mod 10;
a:=a div 100;
S:=a+b+c;
if (9<S)and(S<100) then WriteLn('Сумма цифр(',S,') - двузначное число')
else WriteLn('Сумма цифр(',S,') не является двузначным числом');
if (a=4)or(b=4)or(c=4) then WriteLn('Цифра 4 есть') else WriteLn('Цифры 4 нет');
if (a=7)or(b=7)or(c=7) then WriteLn('Цифра 7 есть') else WriteLn('Цифры 7 нет')
End.

Пример:
Введите трёхзначное число: 74
Сумма цифр(11) - двузначное число
Цифра 4 есть
Цифра 7 есть

Введите трёхзначное число: 71
Сумма цифр(8) не является двузначным числом
Цифры 4 нет
Цифра 7 есть

Введите трёхзначное число: 13
Сумма цифр(4) не является двузначным числом
Цифры 4 нет
Цифры 7 нет
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота