nastyshabos
28.11.2020 00:55

Написать программу с функцией,которая возвращает в основную программу кол-во гласных букв

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
SvetaMew
30.09.2020 22:44

program raf105;

var  

 s: string;

 g: integer;

 

function glas(s:string): integer;

const

 glas_list = 'аяоёуюыиэе';

var  

 i,j,res:integer;

begin

 s:= lowercase(s);

 for i:=1 to length(s) do

   for j:=1 to length(glas_list) do

     if s[i] = glas_list[j]

       then res:= res + 1;

glas:= res;

end;

begin

write('Введите строку: ');

readln(s);

g:= glas(s);

writeln('В строке ',g,' глас.');

end.

PascalABC 3.4.2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота