derwi
14.09.2020 15:03

Составить программу вычисления значения синуса, косинуса и тангенса заданного угла.
(Паскаль)


Составить программу вычисления значения синуса, косинуса и тангенса заданного угла. (Паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
НеУмныйКот
20.09.2021 07:48

В ячейке B3 получится формула: =D$2+$D3  

20+30=50

ответ: 50

Объяснение:

По условию задачи из ячейки A2 скопировали формулу в ячейку В3, то есть мы переместились на позицию вниз и на позицию вправо, значит и значения в формуле: =C$2+$D2  должны изменить свое значения на позицию вниз и вправо: С2 заменилось бы на D3, но знак $ - означает абсолютную ссылку (неизменяемая при перемещении), значит меняется только значение столбца С на D а строка 2 остается неизменной: получается D$2. Аналогично и с $D2, столбец D не изменяется, а строка 2 меняется на 3 получаем  $D3

В итоге в ячейке B3 имеем формулу: =D$2+$D3


Дан фрагмент электронной таблицы. Из ячейки A2 в ячейку B3 была скопирована формула. При копировании
0,0(0 оценок)
Ответ:
qrfeq16
31.03.2021 21:46

1:

print(hex(int(input()))[2:].upper())

Объяснение:

int(input()) ввод числа

hex(x) перевод числа из 10 в 16 с.с. в таком виде 15(10) -> 0xf(16)

[2:] отсекает первые два символа(0x)(просто знай, что они не нужны)

.upper() метод строки, делающий из f -> F

2-ое задание это часть 3-его, поэтому код один и тот же:

alphabet = ''

def now_system_10(x):

   global new_system

   znak = '+'

   if x < 0:

       x = abs(x)

       znak = '-'

   new_x = ''

   lst = []

   while x >= new_system or lst == []:

       if 9 < x % new_system:

           if x % new_system < 20:

               lst += [alphabet[int(str(x % new_system)[1])]]

           elif x % new_system < 30:

               lst += [alphabet[int('1' + str(x % new_system)[1])]]

           else:

               lst += [alphabet[int('2' + str(x % new_system)[1])]]

       else:

           lst += [x % new_system]

       x //= new_system

   if x != 0:

       lst += [x]

   lst.reverse()

   if znak == '-':

       new_x += '-'

   for j in lst:

       new_x += str(j)

   return new_x

num, new_system = map(int, input().split())

print(now_system_10(num))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота