AlexPomanov
04.03.2020 01:42

С клавиатуры вводится строка. Составьте программу, которая выводит знак тире после каждого символа​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vikonil
14.11.2022 00:25

Объяснение:

const nmax=15;

var a:array[1..nmax,1..nmax] of integer;

m,n,i,j,k,x,y:integer;

begin

randomize;

repeat

write('Количество строк до ',nmax,' n=');

readln(n);

until n in [1..nmax];

repeat

write('Количество столбцов до ',nmax,' m=');

readln(m);

until m in [1..nmax];

k:=-1;

for j:=1 to m do

begin

y:=1;

x:=j;

while(x>0) and(y<=n) do

begin

k:=k+1;

a[y,x]:=k;

x:=x-1;

y:=y+1;

end;

end;

for j:=2 to n do

begin

y:=j;

x:=m;

while(x>0)and(y<=n) do

begin

k:=k+1;

a[y,x]:=k;

x:=x-1;

y:=y+1

end;

end;

for i:=1 to n do

begin

for j:=1 to m do

write(a[i,j]:4);

writeln

end;

readln

end.

Переведите на Питон, в Паскале давно не работал

0,0(0 оценок)
Ответ:
wolfbz
18.04.2023 15:12
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
type
  Point=record
  x,y:real
  end;

function GetPoint(c:char):Point;
begin
  Writeln('Введите координаты точки ',c,':');
  Read(Result.x,Result.y)
end;

function Line(A,B:Point):real;
begin
  Result:=sqrt(sqr(B.x-A.x)+sqr(B.y-A.y))
end;

function SqTriangle(pA,pB,pC:Point):real;
begin
  var a:=Line(pB,pC);
  var b:=Line(pA,pC);
  var c:=Line(pA,pB);
  if (a+b>c) and (a+c>b) and (b+c>a) then begin
    var p:=(a+b+c)/2;
    Result:=sqrt(p*(p-a)*(p-b)*(p-c))
    end
  else Result:=0
end;

begin
  var A:=GetPoint('A');
  var B:=GetPoint('B');
  var C:=GetPoint('C');
  Writeln('Площадь треугольника равна ',SqTriangle(A,B,C))
end.

Тестовое решение:
Введите координаты точки A:
-5 3.18
Введите координаты точки B:
1.45 6.2
Введите координаты точки C:
6 -5.93
Площадь треугольника равна 45.98975
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота