vikakotova3
01.03.2023 15:20

1.Составьте программу, которая вставляет заданной слово z после указанного слова t строки s.Строки s, t, z вводится с клавиатуры. 2) С клавиатуры вводится строка, содержащаяся русские буквы и цифры. Составьте программу, позволяющую найти количество:
a) цифр в строке
б) букв в строке
3)Составьте программу, которая выводит на экран последовательность кодов введенной с клавиатуры строки. Узнайте, как будет выглядеть кодировки вашего имени(Карина)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ARTiStlll
04.05.2020 04:52
inputStd() - функция, обеспечивающая безопасный ввод целочисленных значенийfillMatrix() - функция, заполняющая квадратичную матрицу (далее - матрицу) числами из потока вводаexpandMatrix() - функция, которая расширяет вектор из столбцов векторов из целочисленных значений до размера SIZE x SIZEoutputMatrix() - функция, выводящая элементы матрицыfindMax() - функция, находящая максимальный элемент во втором столбце матрицыfindColumnAndStr() - функция, выводящая строку, столбец и значение ячейки, если она меньше максимального элемента второго столбца

Если что-то непонятно - задавайте вопросы в комментарии.


Написать программу на си++.6 нужно
0,0(0 оценок)
Ответ:
ЕкатеринкA
04.05.2020 04:52

Ну, раз матрица дана, пусть она будет А. Напишу в общем случае, так как я не знаю ее размер. Пусть она будет размера n×n.

Дальше код по заданию:

include <iostream>

using namespace std;

void main()

{

double A[5][5];

int n = 5;

for(int i = 0; i < n; i++)

{

int k = i;

for(int j = 0; j< n; j++)

{

A[i][j] = k*2;

}

}

double max = A[0][1];

for(int i = 1; i < n; i++)

{

int j = 1;

if(max < A[i][j])

max = A[i][j];

}

for(int i = 0; i < n; i++)

{

for(int j = 0; j < n; j++)

{

if(max>A[i][j])

{

cout << "Номер строки: " << i << "Номер столбца: " << j << endl;

}

}

}

Вроде бы так)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота