0lar3
22.10.2022 08:32

Напишите программу, которая в последовательности натуральных чисел, заканчивающейся числом 0, определяет сумму чисел, кратных 7 и не превосходящих 150. Если таких чисел нет, вывести сообщение «Не Найдено»

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
светлана440
16.01.2022 01:40

Объяснение:

Датчики являются элементом технических систем, предназначенных для измерения, сигнализации, регулирования, управления устройствами или процессами. Датчики преобразуют контролируемую величину (давление, температура, расход, концентрация, частота, скорость, перемещение, напряжение, электрический ток и т. п.) в сигнал (электрический, оптический, пневматический), удобный для измерения, передачи, преобразования, хранения и регистрации информации о состоянии объекта измерений.

Исторически и логически датчики связаны с техникой измерений и измерительными приборами, например термометры, расходомеры, барометры, прибор «авиагоризонт» и т. д. Обобщающий термин датчик укрепился в связи с развитием автоматических систем управления, как элемент обобщенной логической концепции датчик — устройство управления — исполнительное устройство — объект управления. В качестве отдельной категории использования датчиков в автоматических системах регистрации параметров можно выделить их применение в системах научных исследований и экспериментов.

Датчики являются элементом технических систем, предназначенных для измерения, сигнализации, регулирования, управления устройствами или процессами. Датчики преобразуют контролируемую величину (давление, температура, расход, концентрация, частота, скорость, перемещение, напряжение, электрический ток и т. п.) в сигнал (электрический, оптический, пневматический), удобный для измерения, передачи, преобразования, хранения и регистрации информации о состоянии объекта измерений.

Исторически и логически датчики связаны с техникой измерений и измерительными приборами, например термометры, расходомеры, барометры, прибор «авиагоризонт» и т. д. Обобщающий термин датчик укрепился в связи с развитием автоматических систем управления, как элемент обобщенной логической концепции датчик — устройство управления — исполнительное устройство — объект управления. В качестве отдельной категории использования датчиков в автоматических системах регистрации параметров можно выделить их применение в системах научных исследований и экспериментов

0,0(0 оценок)
Ответ:
DashaDoro03
21.09.2020 09:13
Var
    N, s, i: Integer;
    s1: real;

begin
    readln(N); {общий ввод для всех задач}
    
    if N < 0 then
        writeln('Задача 1. N=', 0)
    else writeln('Задача 1. N=', N + 4);
    
    s := 0;
    for i := 1 to n do
        s := s + i;
    writeln('Задача 7. 1+2+3+…+N=', s);
    
    write('Задача 9. Последовательность от N до 1 = ');
    for i := n downto 1 do
        write(i, ' ');
    writeln();
    
    s1 := 0;
    for i := 1 to n do
        s1 := s1 + i / 10;
    writeln('Задача 12. 0,1+0,2+0,3+..+N/10=', s1);
    
    write('Задача 13. Последовательность квадратов от 1 до N = ');
    for i := 1 to n do
        write(i * i, ' ');
    writeln();
    
    write('Задача 14. Последовательность первых N нечетных чисел = ');
    for i := 1 to n do
        write(2 * i - 1, ' ');
    writeln();
    
    if N > 0 then
        writeln('Задача 20. N степень 3 = ', frac(ln(n) / ln(3)) = 0);
    
    s := 0;
    for i := 1 to n do
        if n mod i = 0 then
            s := s + i;
    writeln('Задача 24. Сумма всех натуральных делителей числа N (сключая 1 и N) = ', s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота