sonechka201
30.04.2023 01:25

с паскалем! ) 1. напишите программу, вычисляющую площадь прямоугольника. с клавиатуры вводятся два действительных числа – стороны прямоугольника. необходимо вычислить его площадь и вывести на экран. вывод должен быть отформатирован следующим образом: под число отводится 10 знаков, а под вещественную часть – 3. 2. с клавиатуры вводятся 3 целых числа. определить количество положительных чисел в этом наборе. 3. с клавиатуры вводится четырехзначное число. получить число, равное произведению его цифр. 4. с клавиатуры вводится натуральное число n. узнайте в нем количество цифр. 5. с клавиатуры вводится натуральное число n. посчитайте сумму s=1+2+…+n. 6. даны целые положительные числа n и k. используя только операции сложения и вычитания, найти частное от деления нацело n на k, а также остаток от этого деления. 7. с клавиатуры вводится натуральное число n. за ним последовательно вводятся данные о росте n учащихся класса. определите средний рост учащихся всего класса. попробуйте решить эту без использования массивов. 8. заполнить элементы массива последовательностью чисел: 2, 5, 10, 17, 26, … 9. вводится число n, а за ним n целых чисел – элементов массива. найдите количество отрицательных элементов в этом массиве. 10. с клавиатуры вводится число n. выведите следующую фигуру (n-строк, на последней строке n звездочек). подсказка: для решения этой примените конструкцию «цикл в цикле». * * * * * * * * * * … * * * * * * * 11. массив заполняется целыми числами до «нуля». замените все положительные числа массив на противоположные им, а отрицательные возведите в квадрат. выведите изменившийся массив. 12. на вход программе поступает целое число n. выведите количество делителей n, включая 1 и само число n. внимание: для решения этой заведите счетчик и не забудьте сначала занести в него значение 0.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Даниюша3223
12.06.2020 12:47

1)

var

  a, b, s : real;

begin

  read (a, b);

  s := a * b;

  write (s:10:4);

end.

 

2)

var

  a, b, c, k : integer;

begin

  read (a, b, c);

  k := 0;

  if a > 0 then inc (k);

  if b > 0 then inc (k);

  if c > 0 then inc (k);

  writeln (k);

end.

 

3)

var

  a : integer;

begin

  read (a);

  writeln ((a mod 10) * (a mod 100 div 10) * (a div 100 mod 10) * (a div 1000));

end.

 

4)

var

  c, n : integer;

begin

  read (n);

  c := 0;

  repeat

    inc (c);

    n := n div 10;

  until n = 0;

  writeln (c);

end.

 

5)

var

  n, sum, i : integer;

begin

  read (n);

  sum := 0;

  for i := 1 to n do

    sum := sum + i;

  writeln (sum);

end.

 

6)

var

  d, n, k : integer;

begin

  read (n, k);

  d := 0;

  while n >= k do

  begin

    d := d + 1;

    n := n - k;

  end;

  writeln ('n div k = ', d);

  writeln ('n mod k = ', n);

end.

 

7)

var

  n, sum, i, tmp : integer;

begin

  read (n);

  sum := 0;

  for i := 1 to n do

  begin

    read (tmp);

    sum := sum + tmp;

  end;

  writeln (sum / n);

end.

 

8)

var

  i, n, s : integer;

  a : array [1..1000] of integer;

begin

  s := 2;

  read (n);

  for i := 1 to n do

  begin

    a[i] := s;

    s := s + 2 * i + 1;

  end;

  for i := 1 to n do write (a[i], ' ');

end.

 

9)

var

  n, i, count, tmp : integer;

begin

  read (n);

  count := 0;

  for i := 1 to n do

  begin

    read (tmp);

    if tmp < 0 then inc (count);

  end;

  writeln (count);

end.

 

10)

var

  n, i, j : integer;

begin

  read (n);

  for i := 1 to n do

  begin

    for j := 1 to i do

      write ('*');

    writeln;

  end;

end.

 

11) //Не понял, как заполняется массив? Тут рандом

var

  a : array [1..1000] of integer;

  i, n : integer;

begin

  read (n);

  for i := 1 to n do

    a[i] := trunc (random (1000)) - 500;

  for i := 1 to n do

    if a[i] > 0 then a[i] := a[i] * (-1)

   else if a[i] < 0 then a[i] := sqr (a[i]);

  for i := 1 to n do

    write (a[i], ' ');

end.

 

12)

var

  n, i, count : integer;

begin

  read (n);

  count := 0;

  for i := 1 to n do

    if n mod i = 0 then inc (count);

  writeln (count);

end.

 

  

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота