Платонф
14.10.2021 22:36

нужно составить программы для Python решая задачи 2. Даны три различных числа A, B, C. Выведите на экран значение среднего из них.
4. Даны три числа, два из которых одинаковые. Выведите на экран значение третьего числа, отличного от двух других.
6. Написать программу, которая по последней цифре числа определяет последнюю цифру её квадрата (цифра, на которую заканчивается квадрат числа, зависит только от последней цифры самого числа)
8. На вход программе подается 3 числа - значение RGB модели некоторого цвета. Известно, что все числа либо равны 255 либо 0. Напишите название цвета, модель которого вам задается.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
спортжизнь
26.01.2023 23:52
Для того, чтобы узнать, не встречалось ли 20-е число раньше, надо помнить, какие числа были до этого. Так что без массива с меньшим размером, чем 19, не обойтись (на самом деле это так, только если в каждом элементе массива хранить только одно число. Но мы так и будем делать). 

Алгоритм для решения задачи выберем простой: записываем все предыдущие числа в массив и для каждого следующего числа проходим по массиву.

var
  a: array[1..19] of byte;
  i, j, t: byte;

begin
  for i := 1 to 20 do
  begin
    read(t);
    if i < 20 then a[i] := t;
    for j := 1 to i - 1 do
      if a[j] = t then
        t := 0;
    if t > 0 then write(t, ' ');
  end;
end.

Пример ввода:
1 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 10 10

Пример вывода:
1 2 3 4 5 6 7 8 9 10
0,0(0 оценок)
Ответ:
я2двойшник
11.04.2021 18:31
Пусть ученик неуспевающий, если сумма его отметок меньше 2+2+3+3=10.

var
  count_losers, sum, current_sum, mark, i, j, n: integer;

begin
  read(n);
  count_losers := 0;
  for i := 1 to n do
  begin
    current_sum := 0;
    for j := 1 to 4 do
    begin
      read(mark);
      current_sum := current_sum + mark;
    end;
    if current_sum < 10 then
      inc(count_losers);
    sum := sum + current_sum;
  end;
  writeln('Неуспевающих учеников: ', count_losers);
  writeln('Средняя сумма четырёх отметок: ', sum / n);
  writeln('Средняя отметка: ', sum / 4 / n);
end.

Пример ввода:
4
2 2 2 5
2 2 5 2
2 5 2 2
3 2 2 2

Пример вывода:
Неуспевающих учеников: 1
Средняя сумма четырёх отметок: 10.5
Средняя отметка: 2.625
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота