svetik83
30.05.2023 08:16

Информатика, python. Условие
На дороге стоят три ларька.

С клавиатуры вводится три целых числа - количество пирожков, которые ларьки продают в месяц.

Власти города хотят снести два менее успешных ларька и оставить только один (самый успешный по продажам). Узнав это, хозяева двух неуспешных ларьков решили объединиться и подать заявление о пересмотре решения сноса.

Если суммарные продажи двух менее успешных ларьков больше продаж одного наиболее успешного, то решение о сносе будет пересмотрено и слияние двух ларьков победит.

Вопрос: кто останется?

Выведите на экран ответ: "успешный ларек" или "слияние двух слабых ларьков" .

Формат входных данных
С клавиатуры вводится три целых положительных числа 0 < m, n, k < 100000

НЕ гарантируется, что первое число максимальное. Наибольшее число надо найти при алгоритма!

Формат выходных данных
ответ фразой.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
PowerDrist
27.11.2020 22:40

питон

n1 = int(input('Введите первое число: '))

n2 = int(input('Введите второе число: '))

n3 = int(input('Введите третье число: '))

l = [(1, n1), (2, n2), (3, n3)]

max_ = None

for i in l:

   if max_ is None:

       max_ = i

   if i[1] > max_[1]:

       max_ = i

l.remove(max_)

if max_[1] > l[0][1] + l[1][1]:

   print('Останется ларек №', max_[0])

else:

   print('Останутся ларьки №', l[0][0], l[1][0])

RAW Paste Data

n1 = int(input('Введите первое число: '))

n2 = int(input('Введите второе число: '))

n3 = int(input('Введите третье число: '))

l = [(1, n1), (2, n2), (3, n3)]

max_ = None

for i in l:

   if max_ is None:

       max_ = i

   if i[1] > max_[1]:

       max_ = i

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота