hchv
05.04.2020 23:46

написать программу в Pascal Построить график функции y=a*(1\x) (a≠0). Значения x меняются в диапазоне от -5 до 5 с шагом 0,25.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Jdjdhdh66t
18.10.2020 19:22
Эта прога может работать не только с 4-ех значными числами
Она на Pascal.

var a,last_num,first_num:integer;

begin
Write('Введите число');
read(a);
last_num:=a mod 10;
first_num:=a;
while first_num>10 do
begin
first_num:= first_num div 10;
end;
writeln('Последняя цифра ', last_num, ', Первая цифра ', first_num);
if first_num > last_num then
writeln('Первая цифра больше')
else if first_num = last_num then
writeln('Они равны')
else if last_num > first_num then
writeln('Последняя цифра больше');
end.
0,0(0 оценок)
Ответ:
Катерина122333
08.06.2020 06:47
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
var a:=ArrRandom(20,2,5);Write('Оценки за диктант: ');a.Println;
Writeln('Двоек: ', a.Where(t-> t = 2).Count);
Writeln('Троек: ', a.Where(t-> t = 3).Count);
Writeln('Четверок: ', a.Where(t-> t = 4).Count);
Writeln('Пятерок: ', a.Where(t-> t = 5).Count);
Writeln('Средний за диктант: ', a.Average:0:2);
end.

Пример:
Оценки за диктант: 4 3 2 3 5 3 3 2 5 2 3 5 4 3 3 4 2 2 3 2
Двоек: 6
Троек: 8
Четверок: 3
Пятерок: 3
Средний за диктант: 3.15
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота