Uchenick2002goda
25.05.2023 23:43

Напишите программу, которая получает на вход номер месяца невисокосного года, а печатает название этого месяца.
Если такого номера месяца не существует, то программа выдаёт сообщение об ошибке.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
amino4ka290805
12.11.2022 15:24

#include<iostream.h>

#include<conio.h>

#include<stdio.h>

 

int main()

 

 {

 

      int b;                                 // наше число b

      clrscr();                           // очищаем экран 

 

      cout<<"Введите b: ";  // Выводим на экран приглашение ввести и  

      cin>>b;                          // b присвиваем введённое значение  

 

         // если b=0 то выводим соответствующее сообщение 

 

        if (b==0)      cout<<"Ноль Совсем Ноль \n "; 

 

       // если b<0 и остаток от деления на 2 =0 то это  отрицательное четное число

        if  ((b<0) && (b%2)==0) cout<<"отрицательное четное число \n ";  

 

// если b<0 и остаток от дления на 2 <>0 то это  отрицательное нечетное число

 if  ((b<0) && (b%2)!=0) cout<<"отрицательное нечетное число \n ";

 

   

 // если b>0 и остаток от деления на 2 =0 то это  положительное   четное число  

        if  ((b>0) && (b%2)==0) cout<<"положительное четное число \n ";  

 

   // если b>0 и остаток от деления на 2 <>0 то это  положительное  нечетное число     

        if  ((b>0) && (b%2)!=0) cout<<" положительное  нечетное число \n ";   

 

  getch();   // ждём нажатия на любую клавишу перед  закрытием

  return 0; // стандартный выход  

 

 

 

 

0,0(0 оценок)
Ответ:
сафаралиев
15.03.2022 06:38
Const n=20;
type omas=array[1..n] of integer;
Procedure Del (var z:omas; k:byte); 
var i:byte; 
begin 
for i:=k to n-1 do z[i]:=z[i+1]; 
z[n]:=0; 
end; 
var a:omas; i,b:integer;
begin
Randomize;
for i:=1 to n do
 begin
 a[i]:=random(20);
 write(a[i]:4);
 end;
writeln;
b:=6;
i:=1;
while (i<=n)and(a[i]<>b) do i:=i+1;
if i<=n then
  begin
  Del(a,i);
 writeln('Размерность массива = ',n-1);
 for i:=1 to n-1 do write(a[i]:4);
 writeln;
 end  else writeln('Массив не изменился');
end.
Пример:
  12  13   6   7  17   1  18  17   3   2  12   3  16   6   7  13   0   2   5  18
Размерность массива = 19
  12  13   7  17   1  18  17   3   2  12   3  16   6   7  13   0   2   5  18
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота