natahakovbasuk
19.02.2021 19:10

Напишите программу в среде программирования кумир


Напишите программу в среде программирования кумир

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Danil200500
17.05.2023 22:52

#include <iostream>

#include <vector>

#include <map>

using namespace std;

int main(){

   int n;

   cin >> n;

   vector<vector<int>> a(n, vector<int> (n));

   vector<int> x(2*n);

   map<int,int> m;

   for(int i = 0; i < n; i++)

       for(int j = 0; j < n; j++)

           cin >> a[i][j];

   int cur1 = 1, cur2 = 0, elem = 0, cnt = 0;

   for(int i = 0; i < n; i++){

       for(int j = 0; j < n; j++){

           if(i == j){

               x[cur1] = a[i][j];

               cur1 += 2;

               m[a[i][j]]++;

               if(m[a[i][j]] > cnt){

                   cnt = m[a[i][j]];

                   elem = a[i][j];

               }

           }

           if(i + j == n - 1){

               x[cur2] = a[i][j];

               cur2 += 2;

               m[a[i][j]]++;

               if(m[a[i][j]] > cnt){

                   cnt = m[a[i][j]];

                   elem = a[i][j];

               }

           }

       }

   }

   for(auto &i : x) cout << i << " ";

   cout << "\nThe most popular element is : " << elem;

}

0,0(0 оценок)
Ответ:
Dan363
19.06.2020 00:19

Код на C++:

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "rus");

   

   const int N = 5;

   int A[N][N], k;

   cout << "Введите матрицу:" << endl;

   for (int i = 0; i < N; i++)

   {

       for (int j = 0; j < N; j++)

       {

           cin >> A[i][j];

       }

   }

   k = 0;

   for (int j = 0; j < N - 1; j++)

   {

       for (int i = j + 1; i < N; i++)

       {

           if (A[i][j] == A[j][i])

           {

               k++;

           }

       }

   }

   if (k == (pow(N, 2) - N) / 2)

   {

       cout << "Да, симметрична!" << endl;

       for (int i = 0; i < N; i++)

       {

           A[i][i] = 0;

           for (int j = 0; j < N; j++)

           {

               cout << A[i][j] << " ";

           }

           cout << endl;

       }

   }

   else

   {

       cout << "Нет, не симметрична!" << endl;

   }

   cin.get();

   

   

   return 0;

};

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота