12СоловьёваАнна
27.06.2022 21:08

Напишите программу на Паскале, для решения задания №3


Напишите программу на Паскале, для решения задания №3

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kiradawn260
27.02.2020 05:52
1-я задача: 3-х литровым кувшином наполняем кувшин 8 л. После 3-го наполнения в 
3-х литровом кувшине останется 1 литр. Затем опорожняем 8 литровый кувшин, с 3-х литрового кувшина переливаем один литр в 8-литровый, и туда -же наливаем два раза по 3 литра - получаем 7 л. 
2-я задача: Песочные часы (3-х минутные и 8 минутные) нужно включить за 8 минут до начала приготовления. Через каждые 3 мин переворачиваем 3 минутные часы. По истечении 8 мин, 3-х минутные песочные часы отсчитают 2 мин. В этот момент нужно начать готовить эликсир, через минуту, переворачиваете 3-мин часы и отсчитываете ещё шесть минут (2 раза по 3 мин) . Вот и получите 7 мин!
0,0(0 оценок)
Ответ:
hanter13
15.06.2022 18:49
//Pascal

//1)
var
  A: array [1..30] of integer;
  i: byte; mult: double;
begin
mult := 1;
randomize;
writeln('Сгенерированный массив.');
for i := 1 to 30 do
begin
  A[i] := random(46)-15;
  if A[i] > 0 then mult := mult * A[i];
  write(A[i], ' ');
end;
writeln;
writeln('Произведение положительных элементов = ', mult);
end.
//

//2)
var
  A: array [1..40] of integer;
  i: byte; count: byte;
begin
count := 0;
randomize;
writeln('Сгенерированный массив.');
for i := 1 to 40 do
begin
  A[i] := random(31)-20;
  if A[i] mod 3 = 0 then count := count + 1;
  write(A[i], ' ');
end;
writeln;
writeln('Количество элементов кратных трем = ', count);
end.
//

//3)
var
  A: array [1..40] of integer;
  i: byte; count: byte; sum: integer;
begin
count := 0; sum := 0;
randomize;
writeln('Сгенерированный массив.');
for i := 1 to 40 do
begin
  A[i] := random(61)-30;
  if A[i] < 0 then
  begin
    count := count + 1;
    sum := sum + A[i];
  end;
  write(A[i], ' ');
end;
writeln;
writeln('Среднее арифметическое отрицательных эл. =',(sum/count):4:4);
end.
//
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота