АУЕшник2281337
13.06.2020 13:47

Составьте программу нахождения в линейном массиве целых чисел из 10 элементов, заполненных случайным образом, произведение нечетных элементов.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vitoriofedorov
25.12.2020 13:27

program z1;

var a:array[1..10] of integer;

i,p:integer;

begin

p:=1;

randomize;

writeln('Массив: ');

for i:=1 to 10 do

begin

a[i]:=random(10);

write (a[i]:3);

if a[i] mod 2 <> 0 then p:=p*a[i]

end;

writeln;

write ('p = ',p)

end.

Объяснение:

р = 1, т.к. при умножении на 1 произведение не изменяется

Заполняем массив используя random

Выводим элемент

Если элемент нечётный, то считаем произведение

Вывод произведения

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота