retrovaweforyou
02.08.2022 15:22

Напишите программу которая заполняет массив 7 случайными числами на отрезке [2;10] и считает отдельную сумму четных и нечетных элементов.
Пример:
Массив: 2 10 3 7 4 8 6
Сумма четных элементов: 30
Сумма нечетных элементов: 10
( язык питон)​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Клава11111
04.06.2022 09:46
Var
  n, m, d: integer;

begin
  Write('Введите трехзначное число: ');
  Readln(n);
  if (n < 100) or (n > 999) then
    Writeln('У Вас странное представление о трехзначных числах!')
  else begin
    d := n div 100; {старшая}
    n := n mod 100;
    m := n div 10; {средняя}
    n := n mod 10; {младшая}
    if (m > d) and (n > m) then
      Writeln('Цифры следуют в возрастающей последовательности')
    else if (m < d) and (n < m) then
      Writeln('Цифры следуют в убывающей последовательности')
    else Writeln('Цифры не образуют монотонную последовательность')
  end
end.

Тестовое решение:

Введите трехзначное число: 159
Цифры следуют в возрастающей последовательности
0,0(0 оценок)
Ответ:
hadizat886
05.06.2021 08:10
На этот вопрос нет однозначного ответа, обычно это зависит от того, какие это данные. Личные данные вроде паролей лучше архивировать сразу в отдельную резервную копию, как только они были изменены. Не слишком нужные, подлежащие восстановлению файлы, вроде выполненных домашних заданий и закачек браузера - примерно раз в неделю, если они могут ещё пригодиться. Файлы, которые легко, но долго восстанавливать (скачанные фильмы и прочие вещи, которые легко, но долго качать ещё раз), можно вообще не добавлять в резервную копию, но если интернет дорогой и не безлимитный, то лучше это делать примерно раз в один-три месяца.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота