LinaCat123456789
12.02.2021 12:36

Составьте программу, задающую одномерный массив целых чисел из 5 элементов, вводимых с клавиатуры, и оформите вывод элементов на экран в строчку.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Erantpay22
25.05.2022 01:05
1.
N=int(input())
s=2
flag=False
for i in range(N):
      if N=s:
           flag=True
           break
      else:
           s*=2
if flag:
    print('Yes')
else:
    print('No')

2.
n=int(input())
def MinDivisor(n):
     nod=-1
     for i in range(n-1):
          if n%i=0:
              return i
              break

if MinDivision(n)==-1:
    print(n,' число является простым.')
else:
    print(MinDivision(n))

3.
A=int(input())
x=x1=1
s=0
while x1<A+2:
   b=x
   x=x1
   x1+=b
   s+=1
if x1==A:
    print(s)
else:
    print(-1)

4. 
a=[]
while 1:
   s=int(input())
   if s==0:
       break
   a.append(s)
a.sort()
print(a[-2])
0,0(0 оценок)
Ответ:
yaooiojhh
25.05.2022 01:05

import java.util.Scanner;

class Main {

   public static void main(String [ ] args) {

       // Инициализация нужных переменных

       Scanner sn = new Scanner(System.in);

       double n = sn.nextInt();

       boolean ts = false;

       // До тех пор, пока n > 1 и n != 2, будет находится его корень. Если в один момент корень будет = 2, то выведется "YES"

       while(n > 1) {

           n = Math.sqrt(n);

           if(n == 2) {

               ts = true;

               break;

           }

       }

       if(ts) {

           System.out.print("YES");

       }

       else {

           System.out.print("NO");

       }

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота