Annakuznetsova2006
06.07.2022 21:23

Напишите программу на паскале: Вывести фигуру треугольника из чисел от 1 до 15 с “вертикальной
разверткой”, т.е. в первом столбике будут числа от 1 до 5, во втором
от 6 до 9 и в последнем 15.
И используйте цикл, чтобы программа была короче.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nikaa10
22.04.2021 00:12
Начнем с формул.
Площадь треугольника: S = 1/2*a*b*sin C
Отсюда: sin C = 2*S/(a*b); cos C = sqrt(1 - sin^2 C)
tg C = sin C / cos C; C = atan(tg C)
Теорема косинусов: c = sqrt(a^2 + b^2 - 2*a*b*cos C)
Площадь: S = c*h/2; отсюда h = 2*S/c
Теорема синусов: a/sin A = b/sin B = c/sin C
Отсюда: sin A = a/c*sin C; sin B = b/c*sin C
cos A = sqrt(1 - sin^2 A); cos B = sqrt(1 - sin^2 B)
tg A = sin A/cos A; A = atan(tg A);
tg B = sin B/cos B; B = atan(tg B)
Периметр: P = a + b + c
Теперь записываем в Паскале
singam := 2*S/(a*b); cosgam = sqrt(1 - singam*singam);
tangam := singam/cosgam; Gamma := atan(tangam);
c := sqrt(a*a + b*b - 2*a*b*cosgam); h := 2*S/c;
P := a + b + c;
sinalp = a/c*singam; cosalp = sqrt(1 - sinalp*sinalp);
tanalp := sinalp/cosalp; Alpha := atan(tanalp);
sinbet = b/c*singam; cosbet = sqrt(1 - sinbet*sinbet);
tanbet := sinbet/cosbet; Beta := atan(tanbet);
0,0(0 оценок)
Ответ:
irna200
15.10.2022 13:56

var

 i, n:integer;

 price:real;

begin

  n := 20;

  price := 20.4;

  for i := 1 to n do

    writeln('Стоимость ', i:3, ' ед. товара составляет ', price * i:8:2, ' руб.');

end.

 

 

//вторая задача

var

  i, f, n:integer;

begin

  f := 453;

  n := 10;

  writeln('фунты    граммы');

  for i := 1 to n do

    writeln(' ', i:2, i * f :11);

end.

 

//третья задача

var

  i, n:integer;

  k:real;

begin

  n := 20;

  writeln('Введите курс '); readln(k);

  writeln('доллары    рубли');

  for i := 1 to n do

    writeln('  ', i:2, i * k:13:2);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота