kirilos2014
07.02.2022 11:58

Дан одномерный массив Y, состоящий из 15 элементов. Подсчитать сумму и произведение элементов массива, меньших 30. Написать программу решения задачи на языке программирования здесь

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
федя92
24.12.2020 18:46

var a: array [1..15] of integer;

i, n, s, p: integer;

begin

s:=0;

p:=1;

Read(n);

For i:= 1 to n do

Read(a[i]);

For i:=1 to n do

if a[n]<30 then begin

s:=s+a[i];

p:=p*a[i];

end;

Write(s, ' ', p);

end.

0,0(0 оценок)
Ответ:
Kristinapermya
24.12.2020 18:46

s,pr = 0,1

Y = []

for i in range(30):

   Y.append(int(input()))

for i in range(30):

   if Y[i] < 30:

       s += Y[i]

       pr *= Y[i]

print(s,pr)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота