составить программу написания имени Эвелина на кумире чертежник

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
igfubvl367
16.03.2023 20:33

2)

#include <iostream>

#include <math.h>

using namespace std;

int main() {

double a;

cin >> a;

double b;

cin >> b;

double c;

cin >> c;

cout << "Уравнение имеет следующий вид:\n";

cout << "(" << a << "x²)+(" << b << "x)+(" << c << ")=0\n\n";

cout << "Посчитаем дискриминант:\n";

double d = (b*b)-4*a*c;

cout << "D=(" << b << "²)-4*(" << a << ")*(" << c << ")" << endl;

cout << "D=(" << b*b << ")-(" << 4*a*c << ")\n";

cout << "D=" << d << "\n\n";

cout << "Теперь узнаем корни дискриминанта:\n";

double x1 = (-b-sqrt(d))/(2*a);

double x2 = (-b+sqrt(d))/(2*a);

cout << "x1=" << x1 << "\n";

cout << "x2=" << x2 << "\n";

return 0;

};

0,0(0 оценок)
Ответ:
BlaSta
07.01.2023 20:31

539 = 10000110112

Объяснение:

Перевод целых десятичных чисел в любую другую системы счисления осуществляется делением числа на основание новой системы счисления (в нашем случае это 2) до тех пор, пока в остатке не останется число меньшее основания новой системы счисления. Новое число записывается в виде остатков деления, начиная с последнего.

Целая часть от деленияОстаток от деления539 div 2 = 269539 mod 2 = 1269 div 2 = 134269 mod 2 = 1134 div 2 = 67134 mod 2 = 067 div 2 = 3367 mod 2 = 133 div 2 = 1633 mod 2 = 116 div 2 = 816 mod 2 = 08 div 2 = 48 mod 2 = 04 div 2 = 24 mod 2 = 02 div 2 = 12 mod 2 = 01 div 2 = 01 mod 2 = 1

Остаток от деления записываем в обратном порядке. Получаем число в 2-ой системе счисления: 1000011011

539 = 10000110112

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота