shariktop000
03.05.2021 11:45

Написать программу нахождения количества нечетных значений элементов массива больше 25 и меньше 99. ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Jisbihish
12.02.2021 18:35

begin

 var size := readinteger;

 var arr := ArrRandomInteger(size, -100, 100);

 arr.Println;

 var quantity := 0;

 for var i := 0 to arr.Length - 1 do

 begin

   if (arr[i] > 25) and (arr[i] < 99) and (arr[i] mod 2 <> 0) then

   begin

     inc(quantity);

   end;

 end;

 write(quantity);

end.

Объяснение:

begin  // Начало программы

 var size := readinteger;   // Переменная, хранящая размер массива, считывается с клавиатуры

 var arr := ArrRandomInteger(size, -100, 100);  // Объявление массива размером size + заполнение массива случайными значениями из диапазона [-100, 100].

 arr.Println;  // Вывод массива

 var quantity := 0;  // Переменная, хранящая количество элементов, равна 0

 for var i := 0 to arr.Length - 1 do  // Идём от нуля до размера массива - 1

 begin  // Начало цикла

   if (arr[i] > 25) and (arr[i] < 99) and (arr[i] mod 2 <> 0) then  // Если значение массива с индексом i > 25 И < 99 И нечетное, тогда

  begin  // Начало условного оператора

   begin  // Начало условного оператора

     inc(quantity);  // Увеличиваем значение переменной quantity на единицу

   end;  // Конец условного оператора

 end;  // Конец цикла

 write(quantity);  // Выводим ответ

end. // Конец программы

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота