podshchipkova
26.12.2021 16:14

написать программу в паскале. Вводятся координаты 5 различных (все координаты различны) точек на плоскости, через первые 3 проходит окружность (в частном случае прямая) через 2 оставшихся прямая. Вывести расстояние от окружности до прямой, если они не пересекаются и сообщение, что пересекаются в противном случае.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
maximyakimov20p00ywe
28.10.2021 13:40
Полный код программы

var
    k, rk, n: longint;

function f(n: longint): longint;
begin
    f := n * n * n;
end;

function calc(k: longint): longint;
var
    i: longint;
begin
    i := 1;
    while f(i) < k do
        i := i + 1;
   
    if f(i) - k <= k - f(i - 1) then
        calc := i
    else calc := i - 1;
end;

begin
    rk := calc(10);
    n := 0;
    for k := 1 to 1000 do
        if calc(k) = rk then
        begin
            writeln('calc(', k, ') = ', calc(k));
            n := n + 1;
        end;
   
    writeln(n);
end.

вывод
calc(5) = 2
calc(6) = 2
calc(7) = 2
calc(8) = 2
calc(9) = 2
calc(10) = 2
calc(11) = 2
calc(12) = 2
calc(13) = 2
calc(14) = 2
calc(15) = 2
calc(16) = 2
calc(17) = 2
13
0,0(0 оценок)
Ответ:
юля6712
28.10.2021 13:40

Для начала смотрим что выходит при К= 36, выходит 5

Анализируем функцию F. Это линейная функция наподобии Фибоначи, значит ответом будет некий один отрезок из К

Потом немножко дорабатываем программу и смотрим на результат


var

   i, K, counter: integer;

function F(x: integer): integer;

begin

   if x < 2 then

       F := 1

   else F := F(x - 1) + 2 * F(x - 2);

end;

begin

   for K := 0 to 100 do  

   begin

       i := 28;

       //        readln(K);

       while (i > 0) and (F(i) > K) do  

           i := i - 1;

       

       if i = 5 then begin

           counter := counter + 1;

           writeln(counter, ') K = ', K);

       end;

   end

end.


Вывод

1) K = 21

2) K = 22

3) K = 23

4) K = 24

5) K = 25

6) K = 26

7) K = 27

8) K = 28

9) K = 29

10) K = 30

11) K = 31

12) K = 32

13) K = 33

14) K = 34

15) K = 35

16) K = 36

17) K = 37

18) K = 38

19) K = 39

20) K = 40

21) K = 41

22) K = 42


ответ 22

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота