Тамик03
03.12.2021 12:04

Написать программу, которая предлагает пользователю ввести число и считает, сколько раз это число встречается в массиве. На языке C#

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
danisdigger
20.10.2022 00:43
1
program z1;
var a,b,c,d, min1, min2, min:real;
begin
writeln ('Введите 4 числа:');
readln (a,b,c,d);
if a<b then
min1:=a
else
min1:=b;
if c<d then
min2:=c
else
min2:=d;
if min1<min2 then
min:=min1
else
min:=min2;
writeln ('Наименьшее число: ',min);
end.

2
program z1;
var a,b,c,d,g,k:real;
begin
writeln ('введите стороны треугольника:');
readln(a,b,c);
if a<b then
begin
k:=a;
d:=b;
end
else
begin
k:=b;
d:=a;
if d<c then
g:=c
else
g:=d;
if g*g=d*d+k*k then
writeln ('треугольник прямоугольный')
else
writeln('треугольник не прямоугольный');
end.
0,0(0 оценок)
Ответ:
1крутой1дядя1
14.01.2021 23:12
# Код на ruby 2.2.3p173
def zadanie(jump1, jump2)
    min = jump1
    for i in 1..1000
        next if (i*jump1)%jump2 == 0 or (i*jump2)%jump1 == 0

        if min > (i*jump1)%jump2
            min = (i*jump1)%jump2
            p [min, "#{i} * #{jump1} - #{i*jump1/jump2} * #{jump2}"]
        end

        if min > (i*jump2)%jump1
            min = (i*jump2)%jump1
            p [min, "#{i} * #{jump2} - #{i*jump2/jump1} * #{jump1}"]
        end
    end
    return min
end
# # Примеры применения
p zadanie(33, 55)

Вывод
[22, "1 * 55 - 1 * 33"]
[11, "2 * 33 - 1 * 55"]
11

Т.е. минимум при 2 * 33 - 1 * 55 = 11
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота