НАДО ПЕРЕПИСАТЬ ЭТУ ПРОГРАММУ ВНЕШНИЙ ЦИКЛ С ПОСТУСЛОВИЕМ А ВНУТРЕННИЙ С ПРЕДУСЛОВИЕМ uses crt ; var X , n:integer ; Y, F:real; begin readln (n); ClrScr; x:=1; for x:=1 to n do begin Y:=1.0; repeat F:= sin(sqr(y))- ln(x*y); writeln ('X=', x:4,' ' :1, 'Y=',Y:4:2,' ':1,'F=', F:4:2); Y:=Y+0.5 Until Y>4.0; end; X:=X+1; end.
Линейный (последовательный) алгоритм — описание действий, которые выполняются однократно в заданном порядке. линейными являются алгоритмы отпирания дверей, заваривания чая, приготовления одного бутерброда. линейный алгоритм применяется при вычислении арифметического выражения, если в нем используются только действия сложения и вычитания.
например алгоритм заварки чая:
вскипятить воду ополоснуть кипятком заварной чайник засыпать в чайник заварку залить кипятком заварной чайник накрыть чайник специальной грелкой подождать до полного заваривания 5 минут
Var a,b,c,n:integer; begin for a:=1 to 7 do for b:=a+1 to 8 do for c:=b+1 to 9 do begin n:=a*100+b*10+c; write(n:4) end; end.
var i,j,n:integer; a:array[1..4,1..5]of real; begin for i:=1 to 4 do begin for j:=1 to 5 do begin a[i,j]:=random*2-1; write(a[i,j]:20:15); if a[i,j]>=0 then n:=n+1; end; writeln; end; writeln('Количество неотрицательных: ',n); end.
var i,j,sum:integer; a:array[1..3,1..4]of integer; begin for i:=1 to 3 do for j:=1 to 4 do readln(a[i,j]); writeln('Массив:'); for i:=1 to 3 do begin for j:=1 to 4 do begin sum:=sum+a[i,j]; write(a[i,j]:4); end; writeln('sum=':8,sum); sum:=0; end; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку