Gaga1111111
19.01.2023 11:15

Напишите программу на C++ Дан одномерный массив C[15].

Задача 1.
Найдите количество отрицательных элементов, стоящих на местах, кратных трём.
Задача 2.
Найдите произведение отрицательных элементов, имеющих нечётное значение.
Задача 3.
Найдите среднее арифметическое значение элементов, которые попадают в интервал [-5; 5].
Задача 4.
Замените элементы массива, которые кратны пяти, на значение максимального элемента массива.
Задача 5.
Осуществите перестановку минимального элемента и элемента, стоящего на последнем месте.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
operovist
04.01.2020 04:48

#include <iostream>

#include <math.h>

using namespace std;


int main(){

int x1,y2,x2,y2, r1, r2;

cin >> x1 >> y1 >> endl; //вводим координаты первой точки

cin >> x2 >> y2 >> endl; //вводим координаты второй точки

r1 = sqrt(x1*x1 + y1*y1); //находим расстояние от первой

r2 = sqrt(x2*x2+y2*y2) //от второй

if (r1>r2){

cout << "Точка 1 ближе к началу координат";

}

else{

cout << "Точка 2 ближе к началу координат";

}

else if (r1=r2){

cout << "Эти точки равны"

}

return 0;

}

0,0(0 оценок)
Ответ:
Head5
04.01.2020 04:48
В основе лежит формула определения расстояния между двумя точками в прямоугольной системе координат, при этом одна из точек совпадает с началом системы координат. В этом случае искомое расстояние определяется по формуле:
L= \sqrt{a_x^2+a_y^2}
Поскольку в задаче не ставится вопрос определения самого расстояния, достаточно для каждой точки вычислить значение L² и сравнить их.
Окончательно задача сводится к нахождению минимального из значений
a_x^2+a_y^2 по заданным координатам х и у.

var
  ax, ay, bx, by, rx, ry: real;

begin
  writeln('Введите координаты первой точки');
  readln(ax, ay);
  writeln('Введите координаты второй точки');
  readln(bx, by);
  rx := sqr(ax) + sqr(ay);
  ry := sqr(bx) + sqr(by);
  if rx < ry then writeln('Первая точка ближе')
  else
  if rx > ry then writeln('Вторая точка ближе')
  else writeln('Обе точки равноудалены')
end. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота