daniilkartel
07.02.2023 03:29

Написать программу для создания списка из 20 элементов, каждый элемент генерируется рандомно в диапазоне от 1 до 1000. Вывести максимальный и минимальный элемент. А так же их позиции в списке (метод index())

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Aigerimajymatova
27.03.2023 14:27

Вы не указали как хранятся данные о студентах и как осуществляется ввод. Попробуйте так, хотя я уже давно в Паскале не писала.

 

program pr1;

procedure CreateMass(var str:mass; n:integer);
var i:integer;
begin
  for i:=1 to n do begin
  write('Введите имя учащегося: ');
  readln(str[i])
  end
end;

procedure SearchN (str:mass; n:integer);
var i, j, s1, s2:integer;
    b:boolean;
begin
  b:=false;
  j:=1;
  while (j <= (n-1)) and (not b) do
  begin
    for i:=j+1 to n do
    begin
      if str[j]=str[i] then
      begin
        b:=true;
        s1:=i;
        s2:=j
      end
    end;
    j:=j+1
  end;
  if (not b) then writeln('Нет двух студентов с одинаковыми именами.') else
  writeln('Студенты с одинаковыми именами - ',str[s1], ' находятся в массиве под номерами ', s1, ' и ', s2, '.')
end;

type mass = array [1..n] of string;
const n = 10;
var str:mass;
begin
  CreateMass(str, n);
  SearchN(str, n)
end.

0,0(0 оценок)
Ответ:
MrKreeD1
28.10.2021 11:31

использовать Чертежник
алг домик
нач
сместиться в точку (3,3)
подпр домик
подпр домик
подпр домик
подпр домик
подпр домик
кон
алг. подпр домик
нач
установить цвет ("желтый")
опустить перо
сместиться на вектор(0,3)
сместиться на вектор(4,0)
сместиться на вектор(0,-3)
сместиться на вектор(-4,0)
поднять перо
сместиться на вектор(0,3)
опустить перо
сместиться на вектор(2,2)
сместиться на вектор(2,-2)
поднять перо
сместиться на вектор(-3,-2)
опустить перо
сместиться на вектор(0,1)
сместиться на вектор(2,0)
сместиться на вектор(0,-1)
сместиться на вектор(-2,0)
поднять перо
сместиться на вектор (5,-1)
кон

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота