Arse20
09.04.2020 03:58

На Напишите программу, которая считывает число x, а затем пишет его, поставив перед ним х пробелов

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
05012008попович
11.01.2023 14:23
Свойства многострочного текстового поля. Для ввода и вывода значений элементов одномерного массива можно воспользоваться многострочным полем (компонент типа ТМеmо), который можно разместить на форме так же, как и другие компоненты. Среди свойств этого компонента есть много таких, которые имели ранее рассмотренные нами компоненты: Name, Color, Font, Enabled, Visible, Height, Width, Top, Left и in. Среди свойств, которых не было предыдущие компоненты, рассмотрим следующие:
ScrollBars (англ. Scroll - прокрутка, bars - прямоугольные полосы) - значение этого свойства определяет наличие или отсутствие на этом компоненте полос прокрутки (горизонтальной - ssHorizontal, вертикальной - ssVertical обоих - ssBoth) для просмотра текста, который выходит за пределы компонента;
ReadOnly (англ. Read - читать, only - только) - значение этого свойства определяет возможность редактирования строк компонента: False - можно редактировать, True - нельзя (только для чтения)
Lines (англ. Lines - линии, строки) - значением этого свойства является набор значений, расположенных в строках этого компонента; каждая строка имеет номер, нумерация строк начинается с 0;
Lines.Count (англ. Count - подсчет) - значение этого свойства равно количеству заполненных данными строк компонента; отметим, что это свойство отсутствует в списке свойств окна Object Inspector.
Тогда при сохранении проекта эти значения также будут сохранены и автоматически появятся в этом поле после запуска проекта на выполнение.
0,0(0 оценок)
Ответ:
Stukaneva
24.11.2021 09:29

Відповідь:

#include <iostream>

using namespace std;

const int size = 10;

void cinarr(int *arr,const int size){

int counter = 1;

for(int i = 0; i < size; i++){

 cout << "Введите " << counter << " елемент массива: ";

 cin >> arr[i];

 counter++;

}

}

void printarr(int *arr, const int size){

for(int i = 0; i < size; i++){

 cout << arr[i] << " ";

}

}

int expression(int *arr,const int size,int number){

int counternumber = 0;

for(int i = 0; i < size; i++){

 if(number == arr[i]){

  counternumber++;

 }

}

return counternumber;

}

int main(){

setlocale(LC_ALL , "Rus");

int number;

cout << "Введите число которое будем искать: ";

cin >> number;

int *arr = new int [size];

cinarr(arr,size);

printarr(arr,size);

cout << "\nТаких чисел в массиве: " << expression(arr,size,number) << endl;;

delete [] arr;

return 0;

}

Пояснення:


Написать программу, которая получает на 10 элементов и записывает их в массив. Также программа получ
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота