NastyaVelly
26.08.2020 23:37

Нужно написать программу скорей всего мне кажется в паскале 1. writel(' вести стоимость перчатки наприм') read (x) 2 стоимость сумки- наприм. 3.стоимость ремня- наприм. 4.если общая сумма больше 800р, то вывести сумму с учетом 10% скидки 5.если сумма меньше 800р, то вывести сумму нужно, !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zhadyra1984
12.06.2020 05:08

program test;
var x: integer;
var y: integer;
var z: integer;
var sum: real;
begin
readln(x);
readln(y);
readln(z);
sum:=x+y+z;
if sum>=800 then sum:=sum -sum/10;

writeln(Trunc(sum));
end.

0,0(0 оценок)
Ответ:
максим1714
12.06.2020 05:08

var x,a,b,sum:integer;

begin

writeln ('Введите стоимость перчатки');

readln (x);

writeln ('Введите стоимость сумки');

readln (a);

writeln ('Введите стоимость ремня');

readln (b);

 

sum:=a+b+x;

 

if (sum>800) then  writeln (sum-(sum/100*10));

if (sum<800) then writeln (sum);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота