Настя20767
02.01.2023 08:19

Нужно написать программу на pascal abc net
Текстовый файл содержит строки различной длины. Общий объём файла не
превышает 1 Мбайт. Строки содержат только заглавные буквы латинского
алфавита (ABC…Z). Определите количество строк, в которых буква E
встречается чаще, чем буква A.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yaku06nastyaozq1r7
02.04.2021 19:07

ответ:

объяснение:

информационная культура — это умение целенаправленно работать с информацией и использовать для ее получения, обработки и передачи компьютерную информационную технологию, современные технические средства и методы.

для свободной ориентации в информационном потоке человек должен обладать информационной культурой как одной из составляющих общей культуры. информационная культура связана с социальной природой человека. она является продуктом разнообразных творческих способностей человека и проявляется в следующих аспектах:

♦ в конкретных навыках по использованию технических устройств, от телефона до персонального компьютера и компьютерных сетей;  

♦ в способности использовать в своей деятельности компьютерную информационную технологию, базовой составляющей которой являются многочисленные программные продукты;  

♦ в умении извлекать информацию из различных источников, как из периодической печати, так и из электронных коммуникационных систем, представлять ее в понятном виде и уметь эффективно использовать;  

♦ во владении основами аналитической переработки информации;  

♦ в умении работать с различной информацией;  

♦ в знании особенностей информационных потоков в своей области деятельности.

неотъемлемой частью информационной культуры является знание информационной технологии и умение применять ее в своей деятельности как для автоматизации рутинных операций, так и для неординарных ситуаций, требующих нетрадиционного творческого подхода.

основными факторами развития информационной культуры являются:

♦ система образования, определяющая общий уровень интеллектуального развития людей;  

♦ информационная инфраструктура, определяющая возможности людей получать, передавать, хранить и использовать информацию;  

♦ развитие страны, определяющей материальные возможности людей при использовании современных информационных технических средств: компьютеров, телевизоров, электронных средств коммуникации и т. п.

одним из существенных показателей информационной культуры в нашей стране является знание языка. сложившаяся ситуация в компьютерной индустрии такова, что практически все современные версии программных продуктов, определяющих информационную технологию, представлены на языке. на этом языке реализуется интерфейс пользователей с основными информационных ресурсов, осуществляется профессиональное взаимодействие с операционными системами компьютеров. в большинстве областей науки, бизнеса и технологий также доминирует язык.

0,0(0 оценок)
Ответ:
mishkasega77798
09.09.2022 11:04
// PascalABC.NET 3.1, сборка 1213 от 04.04.2016
begin
  var m,n:integer;
  Write('Ввведите число строк и столбцов: ');
  Read(m,n);
  Writeln('Исходный массив');
  var L:=MatrixRandom(m,n,-99,99);
  var s:=0;
  for var i:=0 to m-1 do begin
    for var j:=0 to n-1 do begin
      Write(L[i,j]:4);
      if L[i,j]<0 then s+=L[i,j]
      end;
    Writeln
  end;
  Swap(L[0,0],L[m-1,n-1]);
  Writeln('Результирующий массив');
  for var i:=0 to m-1 do begin
    for var j:=0 to n-1 do Write(L[i,j]:4);
    Writeln
  end;
  Writeln('Сумма отрицательных элементов равна ',s)
end.

Тестовое решение:
Ввведите число строк и столбцов: 5 8
Исходный массив
  59  28 -26 -31  -2 -75   6  24
 -41 -50 -34 -31  58  49 -14  44
 -82  15 -47  67   1 -91 -47  -6
 -36  73 -41  87  15  61  87 -36
   3 -19  34 -27  72 -49  45 -69
Результирующий массив
 -69  28 -26 -31  -2 -75   6  24
 -41 -50 -34 -31  58  49 -14  44
 -82  15 -47  67   1 -91 -47  -6
 -36  73 -41  87  15  61  87 -36
   3 -19  34 -27  72 -49  45  59
Сумма отрицательных элементов равна -854
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота