rubaqlo
09.07.2021 14:42

напишите программу вычисления в Паскале АБС периметр и площадь параллелограмма по точкам. Проверте на точках: A (-3; -6); B (4; -6); C (7; -3); D (0; -3)


напишите программу вычисления в Паскале АБС периметр и площадь параллелограмма по точкам. Проверте н

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
лика03481
07.10.2021 12:11
Оператор условия if
Оператор условия if является одним из самых популярных средств, изменяющих естественный порядок выполнения операторов программы.
Он может принимать одну из следующих форм:
•if <условие> then <оператор1>
else <оператор2>;
•if <условие> then <оператор>;
В переводе с английского языка данные форматы можно определить как:
•ЕСЛИ<условие>ТО<оператор1>ИНАЧЕ<оператор2>
•ЕСЛИ<условие>ТО<оператор>
Оператор условия if выполняется следующим образом. Сначала вычисляется выражение, записанное в условии. В результате его вычисления получается значение булевского типа.
В первом случае, если значение выражения есть True (истина) , выполняется <оператор1>, указанный после слова then (в переводе –“то”). Если результат вычисления выражения в условии есть False (ложь) , то выполняется <оператор2>.
Во втором случае, если результат выражения True, выполняется <оператор>, если False - оператор, следующий сразу за оператором if. Операторы if могут быть вложенными.
0,0(0 оценок)
Ответ:
nastya2719
01.07.2021 22:37
#include <iostream>
using namespace std;
int main()
{
int n, sum,howmuch;
sum = howmuch = 0;
cout << "Введите количество элементов массива" << endl;
cin >> n;
int a[n];
for(int i =0; i < n; i++){
cout << "Заполните массив" << endl;
cin >> a[i];
}

for(int i = 0; i < n; i++){
if (a[i] < 0)
{
howmuch++;
sum += a[i];
}
}
cout << "Сумма отрицательных элементов массива:" << sum << endl;
cout <<"Количество отрицательных объектов массива" << howmuch << endl;
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота