vikafirsova
05.05.2021 02:23

Язык программирования Python Из 30 учащихся класса на уроке присутствуют 24 ученика. Напишите программу, высчитывающую процент посещаемости в этом классе.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MisSashaKotik
08.10.2022 15:11

HTML (как сказано ранее) - Язык гипертекстовой разметки (FrontEnd).

Python - Язык программирования. Используется (как сказано ранее) повсюду.

Но автор ответа слегка ошибся.

Писать сайты на Python можно используя его как BackEnd. Для этого существуют фреймворки Django, Flask и другие.

А все что происходит на фронте (показ текста, картинок, анимации итд) это задача HTML, CSS, JS (куча фреймворков под JS).

То есть как бы требуется связка Python + HTML + CSS + ... для написания полноценных сайтов.

Также -- Python - это высокоуровневый язык. То есть в отличии от тех же низкоуровневых (C++, C#) -- на нем быстрее, проще и приятнее писать.

Но есть и минусы:

- Скорость вычислений

- Тяжело получить низкоуровневый доступ к железу (не сможешь так резво бегать по оперативной памяти компьютера, как, например, на C++)

0,0(0 оценок)
Ответ:
ДарьяДуда
02.09.2021 09:24

procedure SortFirstColAsc(p:array[,] of integer);

begin

 var c:=p.Col(0).OrderBy(x->x).ToArray;

 for var i:=0 to p.RowCount-1 do p[i,0]:=c[i]

end;

procedure SortLastColDesc(p:array[,] of integer);

begin

 var j:=p.ColCount-1;

 var c:=p.Col(j).OrderByDescending(x->x).ToArray;

 for var i:=0 to p.RowCount-1 do p[i,j]:=c[i]

end;

begin

 var n:=ReadInteger('Количество строк в матрице:');

 var m:=ReadInteger('Количество столбцов в матрице:');

 Writeln('*** Исходная матрица [',n,',',m,'] ***');

 var a:=MatrRandom(n,m,-99,99);

 a.Println(4); Writeln(4*a.ColCount*'-');

 Writeln('Сортировка по первой колонке');

 SortFirstColAsc(a);

 a.Println(4); Writeln(4*a.ColCount*'-');

  Writeln('Сортировка по последней колонке');

  SortLastColDesc(a);

 a.Println(4)

end.

Пример

Количество строк в матрице: 4

Количество столбцов в матрице: 7

*** Исходная матрица [4,7] ***

 -12  60  18 -46  10   4  26

 32 -73  -2 -88 -70 -46 -17

 -18  94 -41   9 -11  32  94

 32 -18   1 -71 -96 -77  46

Сортировка по первой колонке

 -18  60  18 -46  10   4  26

 -12 -73  -2 -88 -70 -46 -17

 32  94 -41   9 -11  32  94

 32 -18   1 -71 -96 -77  46

Сортировка по последней колонке

 -18  60  18 -46  10   4  94

 -12 -73  -2 -88 -70 -46  46

 32  94 -41   9 -11  32  26

 32 -18   1 -71 -96 -77 -17

Объяснение:

так?

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота