alex110403
28.11.2021 14:19

Составьте программу ввода массива из 10 чисел f[10] и выведите на печать элементы массива в обратном порядке. С++​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Испан1
16.04.2022 22:59
Месяц находим методом половинного деления.
Двоичная запись числа 366 размещается в 9 битах (в 8 битах размещается только 256 чисел, а в 9 битах - уже 512). Следовательно, понадобится задать 8 вопросов и девятой фразой будет ответ.
В году 365 (366) дней. Пусть 366, для 365 рассуждение то же.
Рассмотрим самый худший вариант

Середина года - день номер 366/2=183. Это 1 июля.
Первый вопрос: День рождения в первой половине года?
Допустим, да.

Второй вопрос: День рождения в первом квартале?
Допустим, нет. Следовательно во втором.

Второй квартал - это дни с номерами от 92 до 182. Середина - среднее арифметическое. (92+182)/2=137. Это дата 17 мая.
Третий вопрос: День рождения позднее 17 мая?
Допустим, нет.

Следовательно, интервал дат 1 апреля - 17 мая, 91 день. Опять делим на 2, сужая интервал до 22 дней. Это дата 22 апреля.
Четвертый вопрос: День рождения позднее 22 апреля?
Допустим, нет.

Новый диапазон поиска - 23 апреля - 17 мая. Половиним его.
Пятый вопрос: День рождения позднее 29 апреля?
Допустим, нет.

Поиск сузился до 23 - 29 апреля. Снова берем половину.
Шестой вопрос: День рождения позднее 26 апреля?
Допустим, нет.

Интервал дат 23-26 апреля. Половиним.
Седьмой вопрос: День рождения позднее 24 апреля?
Допустим, да.

Интервал дат 25-26 апреля.
Восьмой вопрос: День рождения 25 апреля?
Допустим, нет

Девятая фраза: Ваш день рождения 26 апреля.

Число
0,0(0 оценок)
Ответ:
mashacat5571
26.03.2021 19:03
// 10.
var
  n: integer;
begin
  read(n);
  Write((n div 100 mod 2 = 0) or (n mod 10 mod 2 = 0) or (n mod 100 div 10 mod 2 = 0));
end.

// 11.
var
  n: integer;
  a,b,c:integer;
begin
  read(n);
  a:=n div 100; b:=n mod 100 div 10; c:=n mod 10;
  Write((a+b=c)or(a+c=b)or(c+b=a));
end.

// 12.
var
  n: integer;
  a,b,c,d:integer;
begin
  read(n);
  a:=n div 1000; b:=n mod 1000 div 10 div 10; c:=n mod 100 div 10; d:=n mod 10;
  Write(a+b+c+d-1=a*b*c*d);
end.

// 13.
var
  n,k: integer;
  a,b,c:integer;
begin
  Write('n,k= '); read(n,k);
  a:=n div 100; b:=n mod 100 div 10; c:=n mod 10;
  Write((b+c<k)and(a>5));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота