куколку
17.08.2020 12:00

Составить программу,которая определяет сколько раз встречается в таблице а максимальное по величине число.pascal.массивы. заранее : )

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
hkkk1gonso
12.06.2020 01:27

const n=100;

m=100;

var A: array[1..n,1..m] of integer;

i,j,maxi,maxj,k: integer;

begin

randomize;

for i := 1 to n do begin

    for j := 1 to m do begin

        A[i,j] := random(100);

    end;

end;

maxi := 1;

maxj := 1;

for i := 1 to n do begin

    for j := 1 to m do begin

        if (A[i,j] > A[maxi,maxj]) then begin

            maxi := i;

            maxj := j;

        end;

    end;

end;

k := 0;

for i := 1 to n do begin

    for j := 1 to m do begin

        if (A[i,j] == A[maxi,maxj]) then k := k + 1;

    end;

end;

writeln('k = ', k);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота