rinnavinn
01.01.2022 07:26

Написать программу в c++
желательно с блок схемой


Написать программу в c++ желательно с блок схемой

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
manawer
09.05.2021 03:29

C++ GNU. Простое заполнение массива, а потом в цикле проверки.

В конце выводим результаты.

Мой вариант решения:

#include <iostream>

using namespace std;

int main()

{

const int size = 20;

int arr[size];

for (int i = 0; i < size; ++i)

{

 cout << "Enter " << i << " element -> ";

 cin >> arr[i];

}

int AllSum = 0;

int EvSum = 0;

int OddSum = 0;

int EvCounter = 0;

int OddCounter = 0;

int SmallThenZero = 0;

for (int i = 0; i < size; ++i)

{

 AllSum += arr[i];

 if (arr[i] < 0) SmallThenZero++;

 if (arr[i] % 2 == 0)

 {

  EvCounter++;

  EvSum += arr[i];

 }

 else

 {

  OddCounter++;

  OddSum += arr[i];

 }

}

cout << "Even numbers counter - " << EvCounter << endl;

cout << "Odd numbers counter - " << OddCounter << endl;

cout << "Even numbers sum - " << EvSum << endl;

cout << "Odd numbers sum - " << OddSum << endl;

cout << "All numbers sum - " << AllSum << endl;

cout << "Small then zero numbers - " << SmallThenZero << endl;

cin.get();

cin.get();

}

0,0(0 оценок)
Ответ:
raisabarsegyan
26.02.2021 08:05

Привет, я тестировал на VS 2017, но разницы нет, я тебя уверяю (по крайней мере в данном случае).

Кратко об моём решении. Запускаю цикл и считываю символ в переменную, если это точка, добавляю к счётчику +1, если доллар - цикл прекращается.

Мой вариант решения:

#include <iostream>

using namespace std;

int main()

{

char symbol;

int counter = 0;

do

{

 cout << "Enter symbol -> ";

 cin >> symbol;

 if (symbol == '.') counter++;

} while (symbol != '$');

cout << "Dot's counter " << counter << endl;

cin.get();

cin.get();

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота