vladbochilo
30.03.2023 20:20

Напишите программу на языке Паскаля вычисляет стоимость покупки в магазине для определения будем считать что в покупаемый набор входят апельсины и яблоки с клавиатуры вводятся: стоимость 1 кг апельсинов ; стоимость 1 кг яблок; вес апельсина и яблок

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
azarenkov409
27.10.2022 13:07

Логическое «ИЛИ» ложно только тогда, когда ложны оба высказывания. Преобразуем выражение: (число <= 50) ИЛИ (число чётное) и проверим все варианты ответа.

Истинно, поскольку истинны оба высказывания:

40, 42, 44, 46, 48, 50.

Истинно, поскольку истинно первое высказывание:

41, 43, 45, 47, 49 не больше 50.

Истинно, поскольку истинно второе высказывание:

52, 54, 56, 58, 60. — чётное.

Ложно, поскольку ложны оба высказывания:

51, 53, 55, 57, 59.

Складываем числа которые являются ложным высказыванием условия:

51 + 53 + 55 + 57 + 59 = 275

ответ: 275

0,0(0 оценок)
Ответ:
arinamerkylceva
25.03.2020 20:27

using System;

namespace ConcoleApplication

{

   class Program

   {

       public static void Main()

       {

           var n = int.Parse(Console.ReadLine());

           var input = Console.ReadLine().Split();

           var maxUneven = 0;

           var index = 0;

           for (var i = 0; i < n; i++)

           {

               var elem = int.Parse(input[i]);

               if (elem % 2 != 0 && elem > maxUneven)

               {

                   maxUneven = elem;

                   index = i;

               }

           }

           Console.WriteLine(index);

       }

   }

}

Объяснение:

сделал ввод массива в одну строку

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота