berezniki14
21.07.2020 13:22

Составить программу на языке Паскаль для вычисления ЭВМ значений переменных

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
privetjakot
19.10.2020 05:04
#include <iostream>
#include <cstdio>
#include <cmath>

int main()
{
//Объявление переменных, освобождение памяти под динам.массив
int i=0,n=0,c=0,max=0,k=0;
double p=1.0;
cin>>n,c;
double *massop = new double[n];
double *mass = new double[n];

//узнаём числа>c, а заодно и значение максимума по модулю
for ( i = 0; i < n; i++)
{
cin>>massop[i];
if (massop[i]>c) k++;
if (fabs(massop[i])>max||fabs(massop[i])=max) max=fabs(massop[i]);
}

cout<<k<<'" элементов больше с"<<endl;

//Находим первый максимальный эл-т
//больше с  не нужно, возьму под другие нужды
for (i = 0; i<n; i++)
{
if (fabs(massop[i])=max) break;
}
c=i;

//Начиная с этого элемента находим произведение последующих
for (i = c; i<n; i++)
{
p=p*massop[i];
}

cout<<"Произведение чисел после максимального по модулю элемента: "<<p<<endl;

//и снова с на левые цели
c=0;
//заполняем начало массива mass отрицательными элементами из massop
for (i=0;i<n;i++)
{
if (massop[i]<0) mass[c]=massop[i];
c++;
}
//а конец-положительными
for (i=0;i<n;i++)
{
if (massop[i]>0||massop[i]=0) mass[c]=massop[i];
c++;
}
//выведем, что вышло после упорядочивания
for (i=0;i<n;i++)
{
cout<<mass[i]<<'/n';
}
}

/*Вот и всё, коллега-сишник :D*/
0,0(0 оценок)
Ответ:
nkaracheva
31.07.2021 14:49
Не сказано, как хранятся данные. Допустим f[1..15] - фамилия, r[1..15] - рост

readln(newr);
for i:=1 to 15 do
  if r[i]<newr then writeln(f[i]);

Ручной ввод:
var
  i,newr:integer;
  f:array[1..15]of string;
  r:array[1..15]of integer;
begin
writeln('Введите фамилии и рост (в см) по убыванию');
for i:=1 to 15 do
  begin
  write('Фамилия: ');
  readln(f[i]);
  write('Рост (в см): ');
  readln(r[i]);
  end;
writeln('Введите рост (в см) нового уч-ка, не совпадающий ни с кем');
readln(newr);
for i:=1 to 15 do  if r[i]<newr then writeln(f[i]);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота