angelshirina20
16.07.2021 05:16

Напишите программу для паскаля. условие: обменять значения двух переменных, используя третью(буферную) переменную

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zaaz123
11.06.2020 23:24

var

  a, b, buf:real;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  buf := a;

  a := b;

  b := buf;

  writeln('a = ', a);

  writeln('b = ', b);

end.

 

 

// без буферной переменной

var

  a, b:real;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  a := a + b;

  b := a - b;

  a := a - b;

  writeln('a = ', a);

  writeln('b = ', b);

end.

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота