FeagTV
24.03.2021 23:22

Написать программу: Вводятся координаты четырёх точек на плоскости, определить могут ли они быть вершинами выпуклого четырёхугольника.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KatyaDihtiar3112
19.07.2020 07:33
Var  
i, j, k : integer; 
 a : array [0..9,0..9] of char; 
procedure U(i,j:integer);  
var c : char; 
begin 
 c:=a[i,j]; a[i,j]:=' ';  
if (c='W')and(a[i+1,j]='B') then U(i+1,j);
  if (c='B')and(a[i+1,j]='W') then U(i+1,j); 
 if (c='W')and(a[i-1,j]='B') then U(i-1,j); 
 if (c='B')and(a[i-1,j]='W') then U(i-1,j); 
 if (c='W')and(a[i,j+1]='B') then U(i,j+1);  
if (c='B')and(a[i,j+1]='W') then U(i,j+1); 
 if (c='W')and(a[i,j-1]='B') then U(i,j-1); 
 if (c='B')and(a[i,j-1]='W') then U(i,j-1); 
end; 
begin  
assign(input,'input.txt');
reset(input); 
 assign(output,'output.txt');
 rewrite(output);  
for i:=1 to 8 do begin  for j:=1 to 8 do
 read(a[i,j]); 
 readln  
end;  
for i:=1 to 8 do
 begin 
 a[0,i]:=' '; a[9,i]:=' ';  a[i,0]:=' '; a[i,9]:=' '  
end; 
 k:=0; 
 for i:=1 to 8 do 
 for j:=1 to 8 do 
 if a[i,j]<>' ' then
begin 
 k:=k+1; U(i,j)  
end;  
write(k); 
 close(output) 
end. 
0,0(0 оценок)
Ответ:
pmalino
19.02.2020 09:53
Var A,B:real;
Begin
//1
Write('Длина = ');ReadLn(A);
Write('Ширина = ');ReadLn(B);
WriteLn('S = ',A*B);
WriteLn('P = ',2*(A+B));
//2
WriteLn;
Write('Кол-во денег: ');ReadLn(A);
Write('Стоимость покупки: ');ReadLn(B);
WriteLn('Сдача: ',A-B);
//3
WriteLn;
Write('Расстояние: ');ReadLn(A);
Write('Стоимость проезда 1 км: ');ReadLn(B);
WriteLn('Стоимость проезда ',A,' км: ',A*B);
//4
WriteLn;
Write('Цена товара: ');ReadLn(A);
Write('Вес покупки: ');ReadLn(B);
WriteLn('Цена покупки: ',A*B);
//5
WriteLn;
Write('Объём в баррелях: ');ReadLn(A);
WriteLn('Объём в литрах: ',A*159);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота