Нурик2266
24.03.2023 14:19

Составить программу которая вводит с клавиатуры длину стороны квадрата вещественного типа и выводит на экран дисплея площадь квадрата. процедура p1 вводит с клавиатуры длину стороны квадрата; функция f1
вычисляет площадь квадрата; процедура p2 выводит на экран результат. процедура p1 и функции f1 - встроенный в программу процедура p2 - записывается как отдельный модуль подключаемый к основной программе. в паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
9109160145davla
24.05.2020 10:21

программа на Turbo pascal 7.1:

содержание progs.pas:

{$N+}{-директива для подключения 8087 препоцессора}
uses output1; {здесь подключаем модуль output1}

var p:double;

function F1(p:double):double;
begin
F1:=Sqr(p);
end;

procedure P1(var p:double);
begin
readln(p);
p:=F1(p);
end;

begin
write('Введите длину стороны квадрата = ');
P1(p);
P2(p);
end.

 

содержание output1.tpu:

{$N+}{-директива для подключения 8087 препоцессора}
unit output1;{здесь объявляем модуль output1}

interface

procedure P2(p:double);

implementation

procedure P2;
begin
writeln('Площадь квадрата = ',p:0:5);
end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота