anmon07
27.05.2020 15:49

Составить программу ввода величины T- времени в течение суток, и выдачи текста: «Вы уже проснулись?», если t =18; «Как работается?», в остальных случаях.
qBasic

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
katy0987
02.09.2022 18:25
Эту колдунью зовут Кодировка КОИ-8. Таблица кодирования: А-Ю, Б-А, В-Б, Г-Ц, Д-Д, Е-Е, Ж-Ф, З-Г, И-Х, Й-И, К-Й, Л-К, М-Л, Н-М, О-Н, П-О, Р-П, С-Я, Т-Р, У-С, Ф-Т, Х-У, Ц-Ж, Ч-В, Ш-Ь, Щ-Ы, Ъ-З, Ы-Ш, Ь-Э, Э-Щ, Ю-Ч, Я-Ъ, Ё-╦ Таблица построена так. Слева стоят буквы по русскому алфавиту, а справа русские буквы, соответствующие английскому алфавиту. @ - Ю (код 40), A - А (41), B - Б, C - Ц, D - Д, E - E, F - Ф, и т.д. Буква Ё - 33-ья в алфавите, она выбивается из ряда в 32 буквы, поэтому превращается не в букву, а в элемент псевдографики. И еще меняется регистр, 1-ая буква маленькая, остальные большие.
0,0(0 оценок)
Ответ:
zdiana1
02.06.2020 00:37
Задача №1

var a:array[1..3, 1..4] of integer; 
i,j,min:integer; 
begin 
for i:=1 to 3 do 
for j:=1 to 4 do begin 
read(a[i,j]); 
if a[i,j]<0 then min:=a[i,j]; 
end; 
for i:=1 to 3 do 
for j:=1 to 4 do 
if (a[i,j]<0) and (a[i,j]<min) then min:=a[i,j]; 
writeln('Минимальное отрицательное число ',min); 
end.

Задача №2
var a:array[1..2, 1..5] of integer; 
i,j:integer; 
begin 
for i:=1 to 2 do 
for j:=1 to 5 do read(a[i,j]); 
for i:=1 to 2 do begin 
for j:=1 to 5 do 
write(a[i,j],' '); 
writeln; 
end; 
end. 

Задача №3
var a:array[1..3, 1..4] of integer; 
i,j:integer; 
begin 
for i:=1 to 3 do 
for j:=1 to 4 do read(a[i,j]); 
for i:=1 to 3 do 
for j:=1 to 4 do 
if a[i,j]=10 then writeln('Номер столбца — ',j,' Номер строки — ',i); 
end. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота