oipoop54
09.11.2020 13:51

Написать программу определения стоимости разговора по телефону с учетом скидки 15%, предоставляемой по субботам и воскресеньям.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tatyankafi
15.01.2021 15:15

Деректер қорын басқару жүйелері

Өз ойыңызбен бөлісіңіз

Біз үлкен көлемдегі деректерді қалай сақтап, өңдейміз?

Деректер қоры дегеніміз не?

Деректер қорын жасау не үшін қажет?

Деректер қорын жинақтауға арналған қандай программаларды білесіңдер?

Кез келген кәсіпорын немесе ұжым Деректер қорын басқару жүйелерін (ДҚБЖ) жасайды. Олардың көмегімен Деректер қорын жасау­ға, ақпараттармен толықтыруға және жұмыс істеуге болатын программалар жинауға болады. Деректер қорын басқару жүйелерінің бірнеше ондаған түрлері бар, олардың көпшілігі – шындығына келгенде басқару жүйелері емес, арнайы дайындалған программалау тілдері. Осы тілді меңгерген әрбір адам қолданушыға ыңғайлы құрылымдағы, кез келген деректер қорын жасап алуына және оларға қажетті басқару элементтерін енгізуіне болады.

ДҚБЖ (Деректер Қорын Басқару Жүйесі) – деректер қорынан деректерді құру, сақтау және алуды автоматтандыруға арналған программалар жиынтығы.

ДҚБЖ үш негізгі функциясы

1) Деректрді анықтау (деректер қорының сипаттамасы);

​2) Деректерді өңдеу;

​3) Деректерді басқару.

Осы функциялардың барлығын Microsoft Access-те толықтай қолдануға болады.

Тағы да осы тақырып бойынша Басқа іс-әрекеттер

Деректер қорына қойылатын талаптар  

✔ мәліметтер қорының мазмұнын көшіруді болдырмау немесе азайту;

​✔пайдаланушы топтардың құқықтары мен талаптарына сәйкес, деректер қорының жекелеген ақпараттық элементтерге енуін жеделдетуді қамтамасыз ету;

​✔ үнемі өсіп отыратын талаптарды қанағаттандыру үшін деректер қорының кеңейтілу мүмкіншіліктерін қамтамасыз ету;

​✔ тек қана дұрыс, алдын ала тексерілген ақпараттарды пайдалануды қамтамасыз етуге мүмкіндік беретін деректер қорының тұтас­тығын сақтау;

​✔деректер қорының, тұтынушылардың жекелеген санаттарының жұмыс істеуіне қажетті белгілі бір ақпараттық элементтерге енуіне ғана рұқсат беру;

​✔ қорға енуді, деректер қорына ақпараттар қосу мен түзетуді тек қана авторлық құқығы бар тұтынушылардың орындауы;

​✔ деректер қорын пайдаланушылардың талабына сәйкес, деректердің элементтерін, түзету, бейнелеу және есептеу құрылғыларын құрудың қарапайымдылығын қамтамасыз ету.

Есіңізде сақтаңыз

Деректерді сақтау – компьютердің маңызды функцияларының бірі. Оның ең көп тараған құралы – Деректер қоры (ДҚ). ДҚ – берілген құрылымдағы ақпараттардан тұратын арнайы форматтағы файл. Берілгендер кесте түрінде дайындалады.

Деректер қоры (ДҚ) – анықталған облысқа жататын деректерді басқару, сақтау және сипаттаудың жалпы ұстанымдарын анықталған ережелер бойынша қарастыратын ұйымдастырылған деректер жиынтығы.

Тағы да осы тақырып бойынша Басқа іс-әрекеттер

Деректердің арасындағы байланыстарды ұйымдастырудың түрлері

Деректердің арасындағы байланыстарды ұйымдастырудың келесі түрлері бар:

1) Иерархиялық;                                                          ​2) Желілік;                                                     ​3) Реляциялық.

Көптеген ДҚ кестелік құрылымда болады. Кестелік құрылымда берілгендердің адрестері жол мен бағананың қиылысуымен анықталады. Кестелерді жобалау кезінде олардың құрылымдарын алдымен қағазда жасаған ыңғайлы. Кестедегі әрбір өріс оның тақырыбына сәйкес болатын жеке мәліметтен тұрады. Әртүрлі кестедегі берілгендерді байланыстыру үшін, әрбір кестедегі жазбаның өзіндік жеке мәнін бере алатын өріс не өрістер жиынтығы болуы тиіс. Мұндай өріс не өрістер жиынтығын негізгі кілт деп атайды.

Объяснение:

0,0(0 оценок)
Ответ:
ник4934
26.06.2021 02:17
Задание 1:

ответ: 150

a = ((35 - 5) / 6) * (28 + ((35 - 5)/6) -3) = 5 * (25 + 5) = 150Задание 2:

ответ: a=9, b=86

b = ((7 * 11 + 4) div 10) + 6 = (81 div 10) + 6 = 86a = (86 mod 10) + 3 = 6 + 3 = 9Задание 3:

ответ: 12

a = 15 - 6 * 2 = 33>15 ? нет => c = 15 - 3 = 12Задание 4:

ответ: 173

for k:=7 to 14 do  s:=s+2*ks = 5 + 2*(7+8+9+10+11+12+13+14) = 173Задание 5А:НачалоВвод a, ba>b ?если да, то Вывод b*2если нет, то Вывод a*2КонецЗадание 5Б:var a, b: integer;begin    readln(a,b);    if a>b then writeln(b*2) else writeln(a*2);end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота