julia00221
21.09.2021 13:43

Написать программу которая по введенной цифре 0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
avetisyana902
24.09.2022 06:17
Program Pr;
Var
a : array [1..100, 1..100] of integer;
i, max, min, j, n: integer;
Begin
cls;
read(n);
min := 100000;
max := -100000;
for i := 1 to n do 
   for j := 1 to n do     
       begin           
           read(a[i,j]);           
           if (a[i,j] > max) then             
               max := a[i,j];           
          if (a[i,j] < min) then             
               min := a[i,j];     
        end;     
 writeln ('Сумма = ', min + max);
writeln ('Разность = ', max - min);
writeln ('Произведение = ', max * min);

End.
0,0(0 оценок)
Ответ:
maя
30.11.2021 01:33
Ошибки

var p,i,x,count: integer;

begin

count := 0;

p := 0 ;

for i := 1 to 4 do begin

read (x);

if x >= 0 then begin

p := p*x;

count := count+1

end

end;

if count > 0 then begin

writeln(х );

writeln(p);

end

else

writeln('NO')

end

Переменная p в начале равняется нулю. В эту переменную будет записываться общее произведение неотрицательных чисел, умножая p на каждое неотрицательное число, но при умножении любого числа на 0 произведение будет 0, поэтому нужно в начале присвоить ей единицуВ конце выводится последнее введённое число, а нужно вывести количествоПосле end не стоит точкаПравильный вариант программы

var p,i,x,count: integer;

begin

count := 0;

p := 1;

for i := 1 to 4 do begin

read (x);

if x >= 0 then begin

p := p*x;

count := count+1

end

end;

if count > 0 then begin

writeln(count);

writeln(p);

end

else

writeln('NO')

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота