лиза2699
27.10.2021 14:54

Написать программу, которая проверяет является ли введенное число двузначным или нет. если условие выполняется, то на экран выводятся число десятков и единиц исходного числа, иначе выводится сообщение "число двузначным не является".

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
daria19802
11.06.2020 20:57
//Pascal ABC.NET 3.1 сборка 1256

Var
 a:integer;
 s:string;
begin
readln(a);
s:=inttostr(a);
if length(s)=2 then
  begin
  writeln('Десятков:',s[1]);
  write('Единиц:',s[2]);
 end
 else
 writeln('Число двузначным не является');
end.

Пример ввода:
27
Пример вывода:
Десятков:2
Единиц:7
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота