lizok210
04.09.2020 09:05

1) Напишите программу, возводящую число во 2-ю и 3-ю степень это только первое. Еще 3 скину, они простые

Поставьте разделитель между заданиями. В качестве разделителя просто фразу в консоль выведите, например "1е задание", "2е задание"и т.д.

2) Напишите программу, решающее любое сложное математическое выражение. Результат само собой в консоль

3) Создайте переменные ВСЕХ типов, приведенных на протяжении двух уроков. Присвойте им значения, соответствующие их типу. Выведите каждую переменную в консоль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Наташа5979
09.07.2022 13:10
Был на свете человек он был обичный как все любил призидента и был нормальным но один раз когда он пошоо гулять с друзьями он упал в яму наткнувшись на блок он кго тронул и о него было видение потом его нашли копы работающие на призедента они розказали ему что Президент взорвет мир и только он мон мир с блока его хотели питать но пришел парень который его началась погоня и парень понял (его звали Дикарь) что человек (он де Эммет) не избранный продалдалась погоня и коп вистрельнул в Эммета пушкой (котороя не взривала а прилипила жучка)
Коп их стрелял но бэтмен их они полетели в Заоблачную даль
К другим крутим людям которие б им мир но из-за жучка прилетели копы и взорвали Заоблачную даль всех посадили в тюрмю но банда Эммета уцелела они пошли к Президенту гле их ожидали и словили все билы без но Эммет вибралса гле подертвовал собой для других и они закончили то что Эммет начал надавали люлей Президенту и копам и мир не взорвался а Эммет вижил!
Конец!
0,0(0 оценок)
Ответ:
Was1231
22.07.2022 19:28
// Использование указателей для создания односвязного списка
// Сделано на базе демонстрационного примера PascalABC.Net
//
// PascalABC.NET 3.2, сборка 1325 от 19.10.2016
type
  PNode=^TNode;
  TNode=record
    data:integer;
    next:PNode;
  end;

function NewNode(d:integer;n:PNode):PNode;
begin
  New(Result);
  Result^.data:=d;
  Result^.next:=n;
end;

procedure WriteNode(a:PNode);
// Вывод односвязного списка
begin
  Writeln('Содержимое односвязного списка: ');
  var p:=a;
  while p<>nil do begin
    Write(p^.data,' ');
    p:=p^.next;
    end;
  Writeln
end;

function SeekNode(k:integer;a:PNode):PNode;
// Поиск элемента со значением k в списке
begin
  var p:=a;
  Result:=Nil;
  while p<>nil do begin
    if p^.data=k then begin Result:=p; break end;
    p:=p^.next
    end
end;

function PredNode(a,f:PNode):PNode;
// Поиск предшественника f среди a
begin
  var p:=a;
  while p^.next<>f do p:=p^.next;
  Result:=p
end;

procedure Clear(a:pNode);
// Разрушение односвязного списка
begin
  var p:=a;
  while p<>nil do begin
    var p1:=p;
    p:=p^.next;
    Dispose(p1); // Память обязательно возвращать
    end
end;

var
  first,found,father,grandfather,greatgrandfather:PNode;
 
begin
  Randomize;
  first:=nil;
  for var i:=1 to 10 do
    first:=NewNode(Random(100),first);
  WriteNode(first); // первоначальное состояние списка
  var k:=ReadInteger('Введите число для поиска в списке');
  found:=SeekNode(k,first);
  if found<>nil then begin
    father:=PredNode(first,found); // отец
    grandfather:=PredNode(first,father); // дед
    greatgrandfather:=PredNode(first,grandfather); // прадед
    greatgrandfather^.next:=father;
    Writeln('Элемент ',grandfather^.data, ' удален');
    Dispose(grandfather);
    WriteNode(first);
    k:=ReadInteger('Введите число для вставки');
    father^.next:=NewNode(k,found);
    WriteNode(first);
    end
  else Writeln('Такого числа в списке нет');
  Clear(first)
end.  

Пример
Содержимое односвязного списка:
11 75 44 86 88 83 92 18 4 23
Введите число для поиска в списке 88
Элемент 44 удален
Содержимое односвязного списка:
11 75 86 88 83 92 18 4 23
Введите число для вставки 40
Содержимое односвязного списка:
11 75 86 40 88 83 92 18 4 23
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота