10count
12.07.2020 07:55

Решите по программированию как мы знаем шоколадки дарят только тем, кто хорошо тест. поэтому в детском саду №603075 решили подарить 228 грамм шоколада каждому ребенку, кто набрал не менее x за тест. шоколад продаётся плитками по 1337 грамм. плитка ломается на кусочки по 228 грамм и эти кусочки детям. остаток не выбрасывается и учитывается в следующем подарке. определите сколько детей получат награду и сколько плиток шоколада для этого необходимо приобрести. формат ввода в первой строке вводится n, x (1 < = n < = 105, 1 < = x < = 109) — количество детей и необходимый минимальный результат теста. в следующей строке вводится n целых положительных чисел не превышающих 109 — результаты теста. формат вывода выведите два числа — количество заслуженных обладателей кусочков шоколада и количество необходимых плиток шоколада.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sarychevalenka
11.06.2020 20:27

program raf105;

var iq,n,x,i,choco,choco_counter,kid_counter: integer;

begin

write('Введите количество детей в детском саду: ');

readln(n);

write('Введите желаемый IQ: ');

readln(x);

writeln('Вводите IQ ',n,' детей по очереди.');

for i:=1 to n do

begin

 readln(iq);

 if iq >= x

   then begin

     if choco div 228 < 1

       then begin

         choco_counter+= 1;

         choco+= 1337;

       end;

     choco-= 228;

     kid_counter+= 1;

   end;

end;

writeln('Награду получат ',kid_counter,' дет.');

writeln('Шоколада потребуется приобрести: ',choco_counter,' плит.');

end.

PascalABC 3.4.2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота