ArturRus2004
12.03.2021 18:05

Напишите программу табулирования функции y(x) на отрезке [-5; 5] (x0= -5, xn= 5) с шагом h=1 (цикл for). в Visual Studio C++


Напишите программу табулирования функции y(x) на отрезке [-5; 5] (x0= -5, xn= 5) с шагом h=1 (цикл f

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
danchik00148
20.04.2021 08:17
Const
n=10;m=7;
var
a:array[1..n,1..m]of integer;
flag,i,j,b:integer;
begin
     for i:=1 to n do
         begin
             writeln;
                 for j:=1 to m do
                      begin
                        a[i,j]:=random(312)-111;
                        write(a[i,j]:4);
                      end;
            end;
writeln;
Writeln('B ?');
readln(b);
for i:=1 to n do
  for j:=1 to m do
      if a[i,j]=b then
          flag:=1;
if flag=1 then
   writeln('Yes')
else
   writeln('N');
end.

вариант 2
const
n=10;m=7;
var
a:array[1..n,1..m]of integer;
k,i,j,b:integer;
begin
     for i:=1 to n do
         begin
             writeln;
                 for j:=1 to m do
                      begin
                        a[i,j]:=random(312)-111;
                        write(a[i,j]:4);
                      end;
            end;
writeln;
Writeln('B ?');
readln(b);
for i:=1 to n do
  for j:=1 to m do
      if a[i,j]=b then
          k:=k+1;
if k<>0 then
   writeln('Yes')
else
   writeln('N');
end.
0,0(0 оценок)
Ответ:
rubcovayana
06.01.2023 05:36

===== PascalABC.NET =====

begin

 // 1

 var a := ArrRandom(7, -4, 5);

 a.Println;

 // 2

 var b := ReadArrInteger('Введи 8 чисел:', 8);

 Println('Сумма четных:', b.Where(p -> p.IsEven).Sum);

 var p := b.Where(p -> p > 4).DefaultIfEmpty.Product;

 if p >0 then

   Println('Произведение элементов, больших 4:', p)

 else

   Println('Нет элементов, больших 4');

 // 3

 var c := ArrRandom(10, -14, 7);

 c.Println;

 Print('Минимальный элемент, больший 5');

 var m := c.Where(p -> p > 5).DefaultIfEmpty.Min;

 if m = 0 then

   Println('отсутствует')

 else

   Println('равен', m);  

 var im := c.IndexMin;

 Println('Миниммальный элемент номер', im + 1, 'равен ', c[im])

end.


Максимум ! написать программы на языке паскаль: 1) дан массив, заданный на интервале [-4; 5], состоя
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота