Shakhinya01
18.03.2020 12:18

РЕШИТЬ ЗАДАЧИ ПО ИНФОРМАТИКЕ
1) Составить программу, которая изменит все элементы массива С [1..100] С ЧЕТНЫМИ НОМЕРАМИ в 2 раза. Полученный массив вывести на экран

2) Составить программу, которая выводит на экран номер и значение элементов массива N[1..K], КОТОРЫЕ ОКАНЧИВАЮТСЯ НА 1.

3) В массиве С[1..50] определить произведение элементов, имеющих положительные значения и нечетный номер. Результат вывести на экран.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Опаснаятётя01
16.08.2021 14:35
// PascalABC.NET 3.0, сборка 1073
const
  m=5;
  n=4;
  a:array[1..m] of real=(2,-7.1,3.2,-5.4,6.9);
  b:array[1..n] of real=(8.1,3.2,-6.4,-3.5);
  k=3;
var
  i,j:integer;
  sk:real;
  s:array[1..m,1..n] of real;
begin
  Writeln('Массив S');
  for i:=1 to m do begin
    for j:=1 to n do begin
      s[i,j]:=a[i]*b[j];
      Write(s[i,j]:7:2)
    end;
    Writeln
  end;
  sk:=0;
  for i:=1 to m do sk:=sk+s[i,k];
  Writeln('Сумма элементов столбца ',k,' равна ',sk)
end.

Результат выполнения программы:
Массив S
  16.20   6.40 -12.80  -7.00
 -57.51 -22.72  45.44  24.85
  25.92  10.24 -20.48 -11.20
 -43.74 -17.28  34.56  18.90
  55.89  22.08 -44.16 -24.15
Сумма элементов столбца 3 равна 2.56
0,0(0 оценок)
Ответ:
Dipper17
04.02.2020 02:28
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main(){
srand(time(0));
int n,m;
cin>>n;
cin>>m;
int **a=new int *[m];
for(int i=0;i<m;i++)
  a[i]=new int[n];
    cout<<"Matrix A:";
      for(int i=0;i<m;i++){
        cout<<"\n";
           for(int j=0;j<n;j++){
                 a[i][j]=rand()%17-7;
                     cout<<a[i][j]<<" ";
}
}
int *b = new int[m];
cout<<"\n Array B:";
for(int j=0;j<n;j++){
b[j]=0;
 for(int i=0;i<m;i++){
   b[j]=b[j]+a[i][j];
     }cout<<b[j]<<" ";
   }
cin.get();
cin.get();
return 0;
}
Блок-схема и программка на с++ получить матрицу а размера , заполненную случайными числами от -7 до
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота