sasha10072004
03.11.2020 17:44

Составьте программу, которая будет выводить разницу двух заранее введеных чисел: Доступные варианты для сложения:
1. print(
2. result(
3. number1
4. result
5. 5
6. number2
7. 2
8. number1 - number2
9. "Разница="

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
leomax2
15.08.2021 07:20
# -*- coding: utf-8 -*-"""Created on Tue Oct 18 16:38:28 2016 @author: imdunkind""" print("Потерянная карточка")n=int(input("Введите кол-во карточек: "))summaCards=0 # сложим все карточкиsumma_range_i=0 # сумма всех чисел for i in range(1,n+1):    summa_range_i+=i # cумма всех N карточек, карточки не повторяются от 1 до N   for i in range(1,n):    a=int(input("Введите номиналы карточек: "))    summaCards+=a # сумма всех карточек, кроме одной, карточки не повторяются 1 не хватает   # summa_range_i-summaCards - разность сумм, узнаем какой карточки нет   print("Потерянная карточка - {}".format(summa_range_i-summaCards))
0,0(0 оценок)
Ответ:
гилеваКсения
16.02.2020 18:52

Значит просто расписать как это должно работать?

Объявляем переменную День, которая будет считывать количество дней.

Вводится H хлеба - общее количество и Z - количество, которое потребляется в день.

Переведем кг в г, чтобы легче было считать: H = H * 1000

Запускается цикл пока H > 0(пока хлеб вообще имеется)

один проход цикла - один день, значит в теле цикла H = H - Z

То есть мы вычитаем из общего кг хлеба суточное потребление.

И увеличиваем переменую День на 1.

После этого цикла выводим переменную День.

Приведу пример на языке с++. В случае ввода H = 1, Z = 50, выводится ответ 20 дней

#include <iostream>

#include <cstdlib>

using namespace std;

int main()

{

int day = 0, Z, N;

cin >> N >> Z;

N = N * 1000;

while(N > 0){

 N = N - Z;

 day++;

}

cout << day << endl;

system("pause");

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота