silverg2005p00xxj
18.03.2020 06:39

Напишите программу, выводящую на экран шахматное поле такого вида: Подсказка: используйте два цикла с параметром, причем один из них будет вложенным. Первый цикл будет обрабатывать строку, а второй –столбец. Для того, чтобы дать программы понять, когда ей нужно сделать пробела ( а это строки 2,4, 6 и 8), нужно использовать условие if (I % 2==0) Если оно верно, то делайте отступ, иначе – cout не будет выводит отступ.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
fivmif
18.02.2020 09:57

Жобалаудың барысын басқаруды жақсарту мақсатында әрбір кезең нақтыланады, яғни кезеңдерге бөлінеді.

Автоматтандырылған жүйені құрудың 4 кезеңі-Жұмыс сипаты, оның нәтижесі немесе орындаушылардың мамандануы бойынша анықталатын АЖ құру сатысының бір бөлігі.

АЖ құру кезеңдерінің мазмұны ГОСТ 34.601-90 1-қосымшасында регламенттелген.

"АС-қа қойылатын талаптарды қалыптастыру" 1-ші сатысында "объектіні тексеру және АС құру қажеттілігінің негіздемесі" 1-ші кезеңінде объект және оның қызметінің түрлері туралы деректер жинауды жүргізеді. Объектінің және оның құрамдас бөліктерінің жұмыс істеу сапасын бағалайды. Автоматтандыру құралдарының көмегімен шешуге болатын мәселелер мен міндеттерді анықтайды. Жүйені құрудың орындылығын бағалаудың техникалық-экономикалық, әлеуметтік және басқа да түрлерін береді.

"АС-қа пайдаланушылардың талаптарын қалыптастыру" 2-ші кезеңінде АС-қа қойылатын талаптарды қалыптастыру үшін бастапқы деректерді дайындайды, пайдаланушылардың талаптарын қалыптастырады және ресімдейді. Автоматтандыру объектісінің сипаттамасы, жүйені әзірлеуге, іске қосуға және пайдалануға рұқсат етілген шығындар, күтілетін нәтиже, жүйені құру және жұмыс істеу шарттары сияқты құжаттарды дайындайды .

3-ші кезеңде" орындалған жұмыс туралы есепті және жүйені (тактикалық-техникалық тапсырма — ТТТ) әзірлеуге өтінімді жасау " 1-ші кезеңде орындалған жұмыстар туралы есепті және ТТТ әзірлеуге өтінімді немесе мазмұны бойынша ұқсас басқа құжатты ресімдейді.

"АС тұжырымдамасын әзірлеу" 2-ші сатысында "объектіні зерделеу" 1-ші кезеңінде автоматтандыру объектісін егжей-тегжейлі зерделейді.

"Қажетті ғылыми-зерттеу жұмыстарын жүргізу" (ҒЗЖ) 2-кезеңінде пайдаланушылардың барлық талаптарын іске асыру мүмкіндігін бағалау және жолдарды іздестіруді орындайды, ҒЗЖ бойынша есептерді ресімдейді және бекітеді.

"АС тұжырымдамасының нұсқаларын әзірлеу және пайдаланушының талаптарын қанағаттандыратын АС тұжырымдамасының нұсқасын таңдау "3-кезеңінде АС тұжырымдамасының, оларды іске асыру жоспарлары мен ресурстарының баламалы нұсқаларын әзірлеуді, артықшылықтары мен кемшіліктерін бағалауды жүргізеді және бірнеше әзірленген оңтайлы нұсқадан таңдайды. Жүйені қабылдау тәртібі мен шарттарын, оның тиімділігін айқындайды.

Объяснение:

0,0(0 оценок)
Ответ:
saschatuba
11.01.2023 16:57

1) summ=0;

k=32+35*2;

for (i=31;i<k;k=k-2)

summ+=i;

std::cout>>summ;

2) summ=0;

k=38+36;

for (i=38;i<k;i++)

summ+=i;

std::cout<<summ;

3) //число n может делиться нацело числами из промежутка от [1;n/2] (только 1 - очевидный делитель, его не учитываем)

kolvo=0;

std::cin>>n;

for (i=2;i<1+n/2;i++)

if (n%i==0) kolvo++;

std::cout<<kolvo;

4) //интервал (m;k) в круглых скобках, значит начальное число m+1, а конечное k-1

std::cin>>M>>K;

for (i=M+1;i<K;i++) //просто к, а не к-1 т.к. когда i будет равно k-1, цикл выполнится в последний раз, как нам и нужно

{

if (i%5==0) kolvo++;

}

std::cout<<kolvo;

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота