Зариама08
19.01.2020 20:41

Напишите программу, которая преобразует сумму денег (целое число), предоставленную пользователем, в минимально возможное количество монет и банкнот достоинством 1, 2, 5, 10, 20, 50 злотых. Кроме того, программа отображает количество всех банкнот и монет.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
valetto
08.11.2020 13:40

Объяснение:

#include <iostream>

int main()

{

   size_t sum, i = 0;

   const size_t nominals[] = { 5000, 2000, 1000, 500, 200, 100, 50, 10, 5, 2, 1 };

       

   std:cin >> sum;

   while(sum)

   {

       if (sum / nominals[i] > 0)

       {

           std::cout << nominals[i] << "  ";

           sum -= nominals[i];

       }

       else

           ++i;

   }

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота